Bug 588455 - SELinux is preventing /usr/sbin/postdrop "getattr" access on /home/marco/log/procmail.
SELinux is preventing /usr/sbin/postdrop "getattr" access on /home/marco...
Status: CLOSED DUPLICATE of bug 588453
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:39ff78c034f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 14:30 EDT by marco
Modified: 2010-05-04 07:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 07:19:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marco 2010-05-03 14:30:06 EDT
Summary:

SELinux is preventing /usr/sbin/postdrop "getattr" access on
/home/marco/log/procmail.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by postdrop. It is not expected that this access
is required by postdrop and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:postfix_postdrop_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /home/marco/log/procmail [ file ]
Source                        postdrop
Source Path                   /usr/sbin/postdrop
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           postfix-2.6.5-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-110.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64 #1
                              SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   168
First Seen                    Sat 17 Apr 2010 01:17:05 PM CEST
Last Seen                     Mon 03 May 2010 07:29:04 PM CEST
Local ID                      b3581479-08f3-4e5d-a974-0404f658ce71
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272907744.818:141497): avc:  denied  { getattr } for  pid=26853 comm="postdrop" path="/home/marco/log/procmail" dev=sdb5 ino=6422530 scontext=system_u:system_r:postfix_postdrop_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1272907744.818:141497): arch=c000003e syscall=5 success=yes exit=128 a0=2 a1=7fff9f229770 a2=7fff9f229770 a3=7fff9f2294b0 items=0 ppid=26850 pid=26853 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=90 sgid=90 fsgid=90 tty=(none) ses=23206 comm="postdrop" exe="/usr/sbin/postdrop" subj=system_u:system_r:postfix_postdrop_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,postdrop,postfix_postdrop_t,user_home_t,file,getattr
audit2allow suggests:

#============= postfix_postdrop_t ==============
allow postfix_postdrop_t user_home_t:file getattr;
Comment 1 Miroslav Grepl 2010-05-04 07:19:56 EDT

*** This bug has been marked as a duplicate of bug 588453 ***

Note You need to log in before you can comment on or make changes to this bug.