Bug 58853 - ES45 / adaptec AIC7899 error Thomas.sharbaugh@compaq.com
ES45 / adaptec AIC7899 error Thomas.sharbaugh@compaq.com
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Diego Novillo
Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-25 16:30 EST by harry.heinisch
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 15:18:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to update aic7xxx driver in 2.4.9-14a to version 6.2.4 from 2.4.17 (163.36 KB, patch)
2002-01-31 07:32 EST, Jeff Wiedemeier
no flags Details | Diff

  None (edit)
Description harry.heinisch 2002-01-25 16:30:06 EST
Description of Problem:
>  ES45 / KZPEA (adaptec) error


    Attempting to install RedHat 7.2 utilizing an Adaptec 7899
    SCSI Control module on a ES45 will result in one of two senarios.

     -  If you install to a disk on the Internal Shelf, the
         installation will go smoothly.

     -  If you install to an External Shelf, after the install
         recognizes the Adaptec 7899 Controller then identifies
         the devices behind it, the system will lock up in a
         loop with the following screen text appearing...

       Synchrouous at 160 Mbytes/sec
       CRC error during Data-In phase
       CRC error in intermediate CRC packet
       Target incorrectly requested a CRC packet

       ---> resets the External Shelf <---
              loops

Version-Release number of selected component (if applicable):


How Reproducible: always


Steps to Reproduce:
1. configure es45 with adaptec 7899 and external shelf/bus
2. install onto a drive on the external shelf/bus
3. 

Actual Results:

system will lock up in a
         loop with the following screen text appearing...

       Synchrouous at 160 Mbytes/sec
       CRC error during Data-In phase
       CRC error in intermediate CRC packet
       Target incorrectly requested a CRC packet

       ---> resets the External Shelf <---
              loops

Expected Results:

Should work on internal or external shelf/bus


Additional Information:
 
newer 6.2.4 adaptec driver fixes the problem
Comment 1 Diego Novillo 2002-01-30 18:07:00 EST
Could you please provide us with the patch?  We cannot check this problem on the
hardware we have.
Comment 2 Jeff Wiedemeier 2002-01-31 07:31:29 EST
Patch will be attached shortly 

In addition to the patch - the kernel config files should be changed to not use
the old aic7xxx driver.

The test for whether the patch applied correctly (including config changes) is
to check the version of the aic driver when it starts in a system that uses it
-- it should be 6.2.4.
Comment 3 Jeff Wiedemeier 2002-01-31 07:32:25 EST
Created attachment 44136 [details]
patch to update aic7xxx driver in 2.4.9-14a to version 6.2.4 from 2.4.17
Comment 4 Diego Novillo 2002-02-06 15:18:25 EST
The adaptec patch has been added to the kernel in the upcoming release.
Comment 5 Beth Uptagrafft 2002-03-13 09:56:27 EST
I'm closing this case because it was fixed in the Feb 22 delivery.  Please let 
us know if you still see any problems with this issue.

Note You need to log in before you can comment on or make changes to this bug.