Bug 588589 - compat-db should contains db-4.3 and db-4.2.
compat-db should contains db-4.3 and db-4.2.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: compat-db (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jindrich Novy
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 22:32 EDT by Kirby Zhou
Modified: 2013-07-02 19:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: compat-db-4.6.21-13.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:00:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirby Zhou 2010-05-03 22:32:46 EDT
RFE: compat-db should contains db-4.3 and db-4.2.

RHEL5 is released with db-4.3, RHEL4 is released with db-4.2.
But compat-db of RHEL6 is based on db-4.5 and db-4.6, it is not in reason.
Comment 2 RHEL Product and Program Management 2010-05-04 00:01:03 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.
Comment 3 Kirby Zhou 2010-05-04 00:18:52 EDT
As it is very important to run programs developped under RHEL5, how to re-open my request? Just reply something here or fire a new RFE bug?
Comment 4 RHEL Product and Program Management 2010-05-04 13:22:10 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.
Comment 5 Bill Nottingham 2010-05-04 13:45:49 EDT
Fixing flags. This is not a future feature; it's a bug.
Comment 6 RHEL Product and Program Management 2010-05-04 14:36:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Jindrich Novy 2010-05-05 02:12:11 EDT
Putting back Request for Enhancement to the bug summary as it is not a bug. Nothing in RHEL6 actually depends on obsolete BDB 4.2 or 4.3. These old BDBs were removed intentionally.
Comment 8 RHEL Product and Program Management 2010-05-05 03:55:30 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.
Comment 9 Kirby Zhou 2010-05-05 07:54:15 EDT
But why there are still compat-db45 and compat-db46? Who need them?
Comment 10 Jindrich Novy 2010-05-05 09:22:59 EDT
Good point. Please see: 
https://bugzilla.redhat.com/show_bug.cgi?id=459710#c3

There was a need to have at least BDB 4.6 in compat-db because of rpm in the time of Fedora 10. BDB-4.3, 4.5, 4.6 are not needed by anything in RHEL6 any more (according to my repoquery investigations).

I'm not sure which third-party software would need any of the older BDBs though. Keeping the latest three BDB releases (4.7.25, 4.6.21 and 4.5.20) in RHEL6 is hopefully sufficient.
Comment 11 Jindrich Novy 2010-05-05 09:35:55 EDT
To be precise, the latest released Oracle BDB version is 5.0.21 (Mar 2010, not included in RHEL6, it is present in the new libdb package). There is also 4.8.26 (released Jan 2010), which is the mainline BDB in current F13 and rawhide.

4.7.25 (Jun 2008) has proven stable what is the reason why it is present in RHEL6.
Comment 12 Bill Nottingham 2010-05-05 11:37:18 EDT
The point is to have compatiblity(In reply to comment #10)
> I'm not sure which third-party software would need any of the older BDBs
> though. Keeping the latest three BDB releases (4.7.25, 4.6.21 and 4.5.20) in
> RHEL6 is hopefully sufficient.    

The point is compatibility for apps built on RHEL 5 and RHEL 4, not earlier Fedora; it's why you'd need the older bdb releases.
Comment 13 Kirby Zhou 2010-05-13 05:51:34 EDT
Who cares rpms stolen from Fedora-10?
We cares software migrated from EL5/EL4 much more.
Comment 14 Jindrich Novy 2010-05-13 07:40:50 EDT
In comment #10 I was describing reasons why db-4.6 and db-4.5 was in compat-db because of, now very obsolete, Fedora 10. My intention was to describe motivation why 4.6 and 4.5 was needed in times of Fedora 10 and that even these (newer versions than in RHEL4 and RHEL5) are now obsolete because the have no dependencies in RHEL6. So I was not speaking about using F10 packages in RHEL6 at all.
Comment 15 Kirby Zhou 2010-05-13 10:25:05 EDT
OK, In my opinion, enterprise customers have a motive to run legacy business software developed at the decade of RHEL4/RHEL5, this is the reason why compat-db43 and compat-db42 are necessary. At the same time, the compatibility of earily Fedora is not necessary.

compat-glibc.EL5 is for EL4, and .EL6 is for EL5.
compat-expat1 is for EL5.
compat-readline43 is for EL4
compat-readline5 is for EL5
compat-gcc-34 is for EL4


compat-db.EL5 is for EL4, but compat-db.EL6 is for nothing meaningful.
Comment 16 Jindrich Novy 2010-05-19 02:37:44 EDT
BDB 4.2 and 4.3 are now added, BDB 4.5 and 4.6 removed.
Comment 18 Alexander Todorov 2010-08-23 11:14:39 EDT
# rpm -qa | grep compat-db | sort
compat-db-4.6.21-15.el6.i686
compat-db-4.6.21-15.el6.x86_64
compat-db42-4.2.52-15.el6.i686
compat-db42-4.2.52-15.el6.x86_64
compat-db43-4.3.29-15.el6.i686
compat-db43-4.3.29-15.el6.x86_64
Comment 19 releng-rhel@redhat.com 2010-11-10 15:00:43 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.