Bug 58875 - Xconfigurator overwrites keyboard settings in XF86Config
Xconfigurator overwrites keyboard settings in XF86Config
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-26 03:25 EST by Eduardo Sanchez
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-26 03:26:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eduardo Sanchez 2002-01-26 03:25:56 EST
Description of Problem:
When executing Xconfigurator in a normal root session for the purposes
of fine-tune the configuration or either take advantage of new features
of updated XFree86 Packages (such as the one in
https://www.redhat.com/support/errata/RHEA-2002-010.html), Xconfigurator
does not ask the user for X keyboard configuration. After configuring
the XFree86 parameters, Xconfigurator saves a XF86Config file that
overrides the keyboard settings entered at installation. Concretely,
Xconfigurator overwrites any value of XkbModel with "pc101" and
XkbLayout with "us" regardless of whichever previous values of these
settings. This is highly problematic since the list of layouts is not
easily available; neither /usr/X11R6/lib/X11/doc/README.Config nor the
XF86Config.4 man page have relevant or useful information in this regard.

Version-Release number of selected component (if applicable):
Xconfigurator-4.9.39-2 and earlier


How Reproducible: every time


Steps to Reproduce:
1. Execute Xconfigurator with a previous non-US working X keyboard setup.
2. 
3. 

Actual Results:
Keyboard configuration overwriten to US parameters


Expected Results:
Either preserve the XkbModel, XkbLayout and related parameters when writing
the XF86Config file or ask the user for input regarding X keyboard settings
and use them when writing the XF86Config file.

Additional Information:
WORKAROUND: Save the newly produced XF86Config with other name, like 
XF86Config.temp; then run xf86config and get a new XF86Config file;
Look at the keyboard settings in that file; write them down and then
replace the xf86config-generated XF86Config with your old
XF86Config.temp; edit the file, and replace the values of XkbModel and
XkbLayout for the correct ones.

HELPFUL: include documentation on X keyboard configuration
paramenters.
Comment 1 Mike A. Harris 2002-01-26 20:38:09 EST
Xconfigurator does not at all allow "tweaking" a configuration file
currently.  It always creates a brand new config file from scratch,
completely ignoring any prior configuration.  As such, when running
Xconfigurator, if you save the config file, all prior configuration
is lost, since the previous config file(s) are totally ignored and
overwritten.

So, while this is extremely inconvenient, it is not a bug.  Always
make a backup copy of any X config files before running Xconfigurator.

It is planned in the future to have a much better X configuration tool
which does in fact read the config file and allow modification and
tweaking.  This will be a primary feature in a future release.

Comment 2 Eduardo Sanchez 2002-01-26 20:50:16 EST
Thank you very much for answering. However, it seems that I did not explain
myself correctly or either you did not understand. Please think about this: I use
a non-us keyboard (say, a Spanish one, with the accents and the q letter).

The problem is that after I run Xconfigurator, the keyboard layout in X goes to
the US layout. I lose all my accents and my q letter. There is not even the
slightest hint on the documentation, either about this shortcoming or how to
implement a workaround.

I see no problem with this:
"Xconfigurator does not at all allow "tweaking" a configuration file
currently.  It always creates a brand new config file from scratch,
completely ignoring any prior configuration.  As such, when running
Xconfigurator, if you save the config file, all prior configuration
is lost, since the previous config file(s) are totally ignored and
overwritten."

It is ok that Xconfigurator should overwrite completely any file; but then
our utility's configuration scope should be broader. Non english speakers are
caught in a catch-22 situation. The important thing here is that if
Xconfigurator always creates a brand- new config file from scratch, it should
ask the user about keyboard settings (very important for non-english speaking
people and for i18n stuff in general), or either document the shortcoming and
provide instructions on how to overcome this by hand-editing the appropriate
file.

Thanks, Eduardo
Comment 3 Mike A. Harris 2002-01-27 01:14:42 EST
No, you explained yourself fine.. I understand the problem.  I think I
perhaps wasn't clear enough though.  I realize Xconfigurators shortcomings
indeed.  These types of issues will indeed be dealt with in a future
X configuration tool release.  The _current_ Xconfigurator tool does not
deal with this.

kbdconfig is used to configure the keyboard settings.
Comment 4 Eduardo Sanchez 2002-01-27 01:49:41 EST
Thank you very much for your answer. Please bear in mind, however, that
kbdconfig is useful for the console only. I tried that and I got a beautiful
us-latin1 layout for consoles, but X still was using the "us" layout, without
any deadkey. My only workaround was, as I put there, to run the older xf86config
in order to grab the appropriate values for the X keyboard settings, as I told you

Note You need to log in before you can comment on or make changes to this bug.