This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 58895 - hotplug doesn't know epson 640U
hotplug doesn't know epson 640U
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-26 20:03 EST by Carlos Morgado
Modified: 2007-04-18 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 19:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Morgado 2002-01-26 20:03:43 EST
hotplug doesn't know the Epson 640U scanner.
This is hotplug-2001_04_24-11 on a RH72 with updates.

Adding 
scanner
	0x0000		0x04b8	0x010c	    0x0		 0x0		0x0		0x0	0x0 0x0		0x0		0x0			0x0
to usb.usermap fixes the problem, even though i'm sure that's not the correct
line (all fields i didn't know got 0x0 :))

/proc/bus/usb/devices says:
T:  Bus=02 Lev=02 Prnt=02 Port=02 Cnt=01 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=ff(vend.) Sub=00 Prot=ff MxPS= 8 #Cfgs=  1
P:  Vendor=04b8 ProdID=010c Rev= 0.01
S:  Manufacturer=EPSON
S:  Product=Perfection640  
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  2mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbscanner
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
Comment 1 Trond Eivind Glomsrxd 2002-01-28 14:42:16 EST
modules.usbmap is part of the kernel
Comment 2 Pete Zaitcev 2002-02-22 14:00:04 EST
Excuse me, but I did this:

[zaitcev@niphredil zaitcev]$ grep 4b8 /lib/modules/2.4.7-10/modules.usbmap |
grep 10c
scanner              0x0003      0x04b8   0x010c    0x0000       0x0000      
0x00         0x00            0x00            0x00            0x00              
0x00               0x00000000

Carlush, please verify that it's present on your setup.
If it is, Trond has to take this bug back.
Comment 3 Carlos Morgado 2002-02-22 18:06:33 EST
[chbm@bean chbm]$ grep 4b8 /lib/modules/2.4.9-13custom/modules.usbmap | grep 10c 
scanner              0x0003      0x04b8   0x010c    0x0000       0x0000      
0x00         0x00            0x00            0x00            0x00              
0x00               0x00000000
[chbm@bean chbm]$ grep 4b8 /lib/modules/2.4.9-13/modules.usbmap | grep 10c
scanner              0x0003      0x04b8   0x010c    0x0000       0x0000      
0x00         0x00            0x00            0x00            0x00              
0x00               0x00000000

it's in both 2.4.9 from errata and my rebuild of 2.4.9-13

i also confirm the line in usb.usermap is needed
Comment 4 Pete Zaitcev 2002-03-16 16:32:29 EST
Carlos, would you please to uncomment the DEBUG=yes statement in
your /etc/hotplug/usb.agent and attach the result? I think the
best would be to plug the printer in after the reboot, to make
sure we aren't having a problem with a read-only root.
If you do that, please attach /var/log/messages as attachement
to the bug.
Comment 5 Carlos Morgado 2002-03-16 21:29:03 EST
I found that hotplut only fails to load scanner on boot. If I replug the scanner
after boot everything works. I also couldn't reproduce the usb.usermap fix after
noticing this and retesting pluged-on-boot versus plug-after-boot, i must assume
it never fixed anything and I was just not paying atention as to when i pluged
in the scanner.
So, this is probably the read-only root problem you mentioned.

This is all i got on messages even with DEBUG=yes

Mar 17 02:16:23 bean kernel: VFS: Mounted root (ext2 filesystem) readonly.
Mar 17 02:16:23 bean kernel: Freeing unused kernel memory: 196k freed
Mar 17 02:16:23 bean kernel: hub.c: USB new device connect on bus1/2, assigned
device number 2
Mar 17 02:16:23 bean kernel: input0: USB HID v1.10 Mouse [Logitech USB Mouse] on
usb1:2.0
Mar 17 02:16:23 bean kernel: hub.c: USB new device connect on bus2/2, assigned
device number 2
Mar 17 02:16:23 bean kernel: hub.c: USB hub found
Mar 17 02:16:23 bean kernel: hub.c: 4 ports detected
Mar 17 02:16:23 bean kernel: hub.c: USB new device connect on bus2/2/3, assigned
device number 3
Mar 17 02:16:23 bean kernel: usb.c: USB device 3 (vend/prod 0x4b8/0x10c) is not
claimed by any active driver.
Comment 6 Trond Eivind Glomsrxd 2002-03-18 12:27:59 EST
OK, then it's not a kernel problem - the correct values are there. Reassigning
to me.
Comment 7 Trond Eivind Glomsrxd 2002-04-11 15:00:19 EDT
Can you give the rpms at http://people.redhat.com/~teg/hotplug/ a try?
Comment 8 Carlos Morgado 2002-04-14 19:11:55 EDT
Tried the hotplug rpms with hwdata from rawhide. WorkedForMe. 
Go ahead and close.

Note You need to log in before you can comment on or make changes to this bug.