Bug 58898 - Internal compiler error with Boost libraries
Internal compiler error with Boost libraries
Status: CLOSED DUPLICATE of bug 57075
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-26 22:14 EST by ksvanhorn
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-26 22:14:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ksvanhorn 2002-01-26 22:14:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
I got an internal compiler error when building the Boost C++ libraries
(www.boost.org), version 1.26.0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download and untar the Boost libraries, version 1.26.0 (www.boost.org)
2. Download and install boost-build-1.0-1.i386.rpm and boost-jam-3.0-1.i386.rpm
(the build page for Boost says where to get these.)
3. jam -sBOOST_ROOT=. -sTOOLS=gcc
	

Actual Results:  Most of the libraries built fine, but the Boost regex libraries
caused
gcc to fail with with an internal compiler error twice.  Here is
the relevant output for the two cases:

gcc-C++-action
libs/regex/build/bin/libboost_regex.a/gcc/release/runtime-link-dynamic/cregex.o 
boost/regex.hpp: In function `iterator 
boost::re_detail::re_is_set_member (iterator, iterator, 
boost::re_detail::re_set_long *, const boost::reg_expression<charT, 
traits_type, Allocator> &) [with iterator = 
boost::re_detail::mapfile_iterator, charT = char, traits_type = 
boost::regex_traits<char>, Allocator = allocator<char>]':
boost/regex/detail/regex_match.hpp:566:   instantiated from
`boost::re_detail::query_match_aux (iterator, iterator,
boost::match_results<iterator, Allocator> &, const boost::reg_expression<charT,
traits, Allocator2> &, unsigned int,
boost::re_detail::_priv_match_data<iterator, Allocator> &, iterator *) [with
iterator = boost::re_detail::mapfile_iterator, Allocator = allocator<char>,
charT = char, traits = boost::regex_traits<char>, Allocator2 = allocator<char>]'
boost/regex/detail/regex_match.hpp:1114:   instantiated from
`boost::re_detail::reg_grep2 (Predicate, I, I, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int, A2) [with
Predicate = boost::re_detail::pred4, I = boost::re_detail::mapfile_iterator,
charT = char, traits = boost::regex_traits<char>, A = allocator<char>, A2 =
allocator<char>]'
boost/regex/detail/regex_match.hpp:1773:   instantiated from `boost::regex_grep
(Predicate, iterator, iterator, const boost::reg_expression<charT, traits,
Allocator2> &, unsigned int) [with Predicate = boost::re_detail::pred4, iterator
= boost::re_detail::mapfile_iterator, charT = char, traits =
boost::regex_traits<char>, Allocator = allocator<char>]'
libs/regex/build/../src/cregex.cpp:387:   instantiated from here
boost/regex.hpp:244: Internal compiler error in scan_region, at 
except.c:2809
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

    g++  -c -Wall -ftemplate-depth-100  -DNDEBUG -DBOOST_RE_NO_LIB=1  -O4
-finline-functions -Wno-inline   -I"libs/regex/build" -I"."   -o
"libs/regex/build/bin/libboost_regex.a/gcc/release/runtime-link-dynamic/cregex.o" 
"libs/regex/build/../src/cregex.cpp" 

...failed gcc-C++-action
libs/regex/build/bin/libboost_regex.a/gcc/release/runtime-link-dynamic/cregex.o
...

---------------------

gcc-C++-action
libs/regex/build/bin/libboost_regex.so/gcc/release/runtime-link-dynamic/shared-linkable-true/cregex.o 
boost/regex.hpp: In function `iterator 
boost::re_detail::re_is_set_member (iterator, iterator, 
boost::re_detail::re_set_long *, const boost::reg_expression<charT, 
traits_type, Allocator> &) [with iterator = 
boost::re_detail::mapfile_iterator, charT = char, traits_type = 
boost::regex_traits<char>, Allocator = allocator<char>]':
boost/regex/detail/regex_match.hpp:566:   instantiated from
`boost::re_detail::query_match_aux (iterator, iterator,
boost::match_results<iterator, Allocator> &, const boost::reg_expression<charT,
traits, Allocator2> &, unsigned int,
boost::re_detail::_priv_match_data<iterator, Allocator> &, iterator *) [with
iterator = boost::re_detail::mapfile_iterator, Allocator = allocator<char>,
charT = char, traits = boost::regex_traits<char>, Allocator2 = allocator<char>]'
boost/regex/detail/regex_match.hpp:1114:   instantiated from
`boost::re_detail::reg_grep2 (Predicate, I, I, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int, A2) [with
Predicate = boost::re_detail::pred4, I = boost::re_detail::mapfile_iterator,
charT = char, traits = boost::regex_traits<char>, A = allocator<char>, A2 =
allocator<char>]'
boost/regex/detail/regex_match.hpp:1773:   instantiated from `boost::regex_grep
(Predicate, iterator, iterator, const boost::reg_expression<charT, traits,
Allocator2> &, unsigned int) [with Predicate = boost::re_detail::pred4, iterator
= boost::re_detail::mapfile_iterator, charT = char, traits =
boost::regex_traits<char>, Allocator = allocator<char>]'
libs/regex/build/../src/cregex.cpp:387:   instantiated from here
boost/regex.hpp:244: Internal compiler error in scan_region, at 
except.c:2809
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

    g++  -c -Wall -ftemplate-depth-100  -DNDEBUG -DBOOST_RE_BUILD_DLL=1  -O4
-finline-functions -Wno-inline -fPIC   -I"libs/regex/build" -I"."   -o
"libs/regex/build/bin/libboost_regex.so/gcc/release/runtime-link-dynamic/shared-linkable-true/cregex.o" 
"libs/regex/build/../src/cregex.cpp" 

...failed gcc-C++-action
libs/regex/build/bin/libboost_regex.so/gcc/release/runtime-link-dynamic/shared-linkable-true/cregex.o
...





Expected Results:  The compiler should not have crashed.

Additional info:
Comment 1 Jakub Jelinek 2002-01-28 06:14:35 EST

*** This bug has been marked as a duplicate of 57075 ***

Note You need to log in before you can comment on or make changes to this bug.