Bug 58925 - Bind refuses to run with -u not supported on Linux kernels older than 2.3.99-pre3 or 2.2.18 when using threads
Summary: Bind refuses to run with -u not supported on Linux kernels older than 2.3.99-...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bind
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 59079 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-28 02:35 UTC by Brian Bruns
Modified: 2007-04-18 16:39 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2002-02-28 02:24:39 UTC


Attachments (Terms of Use)

Description Brian Bruns 2002-01-28 02:35:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Windows NT 5.0; U)

Description of problem:
Bind refuses to run with the following error message:

[root@summit autoupdate]# named -u named
named: -u not supported on Linux kernels older than 2.3.99-pre3 or 2.2.18 when using threads
[root@summit autoupdate]#

Problem does not exist if src rpm is rebuild on the local machine, and rebuild rpm will work on any other Rawhide machine.  Looks like a problem 
with the i386 rpm from the rawhide site

Version information:
RPM: bind-9.2.0-3
Kernel: 2.4.18pre1
Arch: i686 (Dual Pentium II 333mhz)
Glibc version: glibc-2.2.90-3


Anything else you need to know?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install rpm
2. start either using the named initscript, or 'named -u named'
	

Actual Results:  [root@summit autoupdate]# named -u named
named: -u not supported on Linux kernels older than 2.3.99-pre3 or 2.2.18 when using threads
[root@summit autoupdate]#

Expected Results:  Bind daemon should start normally.

Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-01-31 10:19:07 UTC
*** Bug 59079 has been marked as a duplicate of this bug. ***

Comment 2 Need Real Name 2002-02-28 02:24:35 UTC
I would like to vote for this bug; i'm having similar problems since 
I upgraded from bind-9.2.0-2 to bind-9.2.0-3

regards,

Mark



Comment 3 Bernhard Rosenkraenzer 2002-03-01 11:09:38 UTC
This was fixed in -4


Note You need to log in before you can comment on or make changes to this bug.