Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 589353 - [abrt] crash in gwaei-1.3.0-3.fc12: Process /usr/bin/gwaei was killed by signal 11 (SIGSEGV)
[abrt] crash in gwaei-1.3.0-3.fc12: Process /usr/bin/gwaei was killed by sign...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gwaei (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: René Ribaud
Fedora Extras Quality Assurance
abrt_hash:4340bab5b7a68bbd9756af8227f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 18:40 EDT by afgonzaga
Modified: 2010-05-24 15:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: gwaei-1.3.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 15:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (25.91 KB, text/plain)
2010-05-05 18:40 EDT, afgonzaga
no flags Details

  None (edit)
Description afgonzaga 2010-05-05 18:40:21 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: gwaei
component: gwaei
crash_function: gw_resultline_parse_edict_result_string
executable: /usr/bin/gwaei
global_uuid: 4340bab5b7a68bbd9756af8227f85b377f6d6248
kernel: 2.6.32.11-99.fc12.i686.PAE
package: gwaei-1.3.0-3.fc12
rating: 4
reason: Process /usr/bin/gwaei was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.  Searched for the word "hello" (without the quotes).
2.
3.
Comment 1 afgonzaga 2010-05-05 18:40:23 EDT
Created attachment 411757 [details]
File: backtrace
Comment 2 afgonzaga 2010-05-05 19:38:21 EDT
(In reply to comment #0)
> abrt 1.0.9 detected a crash.
> 
> architecture: i686
> Attached file: backtrace
> cmdline: gwaei
> component: gwaei
> crash_function: gw_resultline_parse_edict_result_string
> executable: /usr/bin/gwaei
> global_uuid: 4340bab5b7a68bbd9756af8227f85b377f6d6248
> kernel: 2.6.32.11-99.fc12.i686.PAE
> package: gwaei-1.3.0-3.fc12
> rating: 4
> reason: Process /usr/bin/gwaei was killed by signal 11 (SIGSEGV)
> release: Fedora release 12 (Constantine)
> 
> How to reproduce
> -----
> 1.  Searched for the word "hello" (without the quotes).
> 2.
> 3.    

Search for anything and the application crashes...
Comment 3 René Ribaud 2010-05-06 05:33:54 EDT
Hello,

First thanks to report the bug.

To better understand the behavior.

Can I ask you to :

- tell me which dictionaries were installed ?
- start gwaei from a shell and copy / paste the messages from it.
- list files in ~/.waei and copy / paste result, this directory should exist and should contain dictionaries.

Best regards.
René.
Comment 4 afgonzaga 2010-05-06 06:01:54 EDT
1.  All dictionaries are installed except for example and Spanish.
2.  ~]$ gwaei 
    0 English Dictionary
    1 Kanji Dictionary
    2 Names Dictionary
    3 Places Dictionary
    4 German Dictionary
    5 French Dictionary

    6 dictionaries are being used.
    Segmentation fault (core dumped)
3.  -rw-rw-r--   1 MyUser MyUser 132K 2010-05-06 00:44 Radicals
    -rw-rw-r--   1 MyUser MyUser 1.2M 2010-05-06 00:44 Kanji
    -rw-rw-r--   1 MyUser MyUser 1.3M 2010-05-06 00:44 Mix
    -rw-rw-r--   1 MyUser MyUser  12M 2010-05-06 00:44 English
    -rw-rw-r--   1 MyUser MyUser  12M 2010-05-06 00:46 Places
    -rw-rw-r--   1 MyUser MyUser  19M 2010-05-06 00:46 Names
    -rw-rw-r--   1 MyUser MyUser  22M 2010-05-06 00:47 German
    -rw-rw-r--   1 MyUser MyUser 1.1M 2010-05-06 00:47 French
    drwxr-xr-x   3 MyUser MyUser 4.0K 2010-05-06 00:47 .
    drwx------ 118 MyUser MyUser 4.0K 2010-05-06 16:05 ..
    drwxr-xr-x   2 MyUser MyUser 4.0K 2010-05-06 17:55 download


(In reply to comment #3)
Comment 5 Zachary Dovel 2010-05-06 14:51:11 EDT
Hello, afgonzaga.  Does it crash with other dictionary files, too?  I am wondering if maybe your dictionary is corrupt and needs to be redownloaded.  I presently can't reproduce the crash, but I am looking into it.
Comment 6 Zachary Dovel 2010-05-09 02:49:54 EDT
I have verified the problem on an Ubuntu machine.  It is because not all of the dictionary file is being written to the hard disk when the file encoding is converted.  (If you quit and restart the program after install without doing a search, you will have a correctly working dictionary.)  This is thanks to how ext4 doesn't like to write to the hard disk immediately.

Need to convert the two close functions to fclose now.
Comment 7 René Ribaud 2010-05-13 17:50:16 EDT
Hello afgonzaga,

I have done a package with gwaei-1.3.1 provided by Zachary.
Before releasing it to the Fedora repository.

Could you please try to update gwaei on your system and let us know if the bug is fixed on your side ?

You can find the package here :
http://uggla.free.fr/rpmbuild/RPMS/12/i386/gwaei-1.3.1-1.fc12.i686.rpm

[ctb@uggla i386]$ sha256sum gwaei-1.3.1-1.fc12.i686.rpm
c01e9c0c6f85685f98702fd974c87260f1e47e7cff6ff93f493f79df2452deb5  gwaei-1.3.1-1.fc12.i686.rpm

Best regards.
René
Comment 8 afgonzaga 2010-05-14 12:35:35 EDT
ok... will be giving feedback as soon as i finish testing... thanks a lot...
Comment 9 afgonzaga 2010-05-19 11:54:03 EDT
sorry for the delay, got tied up at work... so far so good... gwaei hasn't crashed once since the update... thanks a lot for the support...
Comment 10 Fedora Update System 2010-05-21 14:55:11 EDT
gwaei-1.3.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwaei-1.3.1-1.fc13
Comment 11 Fedora Update System 2010-05-21 14:55:17 EDT
gwaei-1.3.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwaei-1.3.1-1.fc12
Comment 12 Fedora Update System 2010-05-24 15:36:04 EDT
gwaei-1.3.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-05-24 15:45:55 EDT
gwaei-1.3.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.