Bug 58938 - MTU option in DHCP response ignored
Summary: MTU option in DHCP response ignored
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-28 10:48 UTC by Need Real Name
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 16:03:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-01-28 10:48:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20020102

Description of problem:
Pump does not appear to respond to the 'interface-mtu' option supplied in
dhcpd.conf. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Server is stock RedHat 7.1, running dhcp-2.0pl5-4, with 'options
interface-mtu 1300' in the configuration.
2. Client is stock RedHat 7.2, running pump-0.8.11-7.
3. Boot up client.
	

Actual Results:  Client obtains network setup correctly from server except for
MTU, which remains at the default 1500. It needs to be stepped down to work
properly when connected to BT Surftime in the UK, because of their ridiculous
tunnelling setup.

Expected Results:  Pump should have configured interface's MTU.

Additional info:

It needs to be stepped down to work properly when connected to BT Surftime in
the UK, because of their ridiculous tunnelling setup. I'm guessing it's fairly
easy to add this, but I haven't had a chance to look at it, so I guess it should
be filed as a bug.

Comment 1 Eido Inoue 2004-01-05 16:03:48 UTC
closing as supported products don't use pump anymore


Note You need to log in before you can comment on or make changes to this bug.