Bug 589392 - SELinux is preventing dbus-daemon (unlabeled_t) "write" unlabeled_t.
SELinux is preventing dbus-daemon (unlabeled_t) "write" unlabeled_t.
Status: CLOSED DUPLICATE of bug 589402
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:bc2f876e47f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 23:17 EDT by Naoki
Modified: 2010-05-06 03:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 03:47:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naoki 2010-05-05 23:17:44 EDT
Summary:

SELinux is preventing dbus-daemon (unlabeled_t) "write" unlabeled_t.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by dbus-daemon. It is not expected that this
access is required by dbus-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:object_r:unlabeled_t:s0
Target Context                system_u:object_r:unlabeled_t:s0
Target Objects                socket [ unix_stream_socket ]
Source                        dbus-daemon
Source Path                   /bin/dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.2.4.4permissive-4.fc11
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.8-1.fc11
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.29-0.197.rc7.fc11.i586
                              #1 SMP Tue Mar 3 23:01:11 EST 2009 i686 i686
Alert Count                   62
First Seen                    Sun 08 Mar 2009 06:02:14 PM JST
Last Seen                     Mon 09 Mar 2009 11:01:45 AM JST
Local ID                      d48ae4bc-aa34-44fc-8a3b-c89fd7b9e5ef
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1236564105.77:4992): avc:  denied  { write } for  pid=13190 comm="dbus-daemon" path="socket:[112854]" dev=sockfs ino=112854 scontext=system_u:object_r:unlabeled_t:s0 tcontext=system_u:object_r:unlabeled_t:s0 tclass=unix_stream_socket

node=(removed) type=SYSCALL msg=audit(1236564105.77:4992): arch=40000003 syscall=146 success=yes exit=168 a0=41 a1=bfd53050 a2=2 a3=b7fac120 items=0 ppid=1 pid=13190 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=98 comm="dbus-daemon" exe="/bin/dbus-daemon" subj=system_u:object_r:unlabeled_t:s0 key=(null)



Hash String generated from  catchall,dbus-daemon,unlabeled_t,unlabeled_t,unix_stream_socket,write
audit2allow suggests:

#============= unlabeled_t ==============
allow unlabeled_t self:unix_stream_socket write;
Comment 1 Miroslav Grepl 2010-05-06 03:47:53 EDT

*** This bug has been marked as a duplicate of bug 589402 ***

Note You need to log in before you can comment on or make changes to this bug.