Bug 589425 - Please bring the minor RHEL version back in info output
Summary: Please bring the minor RHEL version back in info output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Retired
Component: Test Suite (tests)
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Guangze Bai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 06:15 UTC by QinXie
Modified: 2015-02-08 21:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In v7 1.2, a regression occured that info test only printed the major version of RHEL. This issue has been fixed in v7 1.3, now v7 prints both major and minor version information in info test.
Clone Of:
Environment:
Last Closed: 2011-05-09 16:15:23 UTC


Attachments (Terms of Use)
info test patch to show minor version if present (731 bytes, patch)
2011-01-20 21:42 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0497 0 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-05-09 16:11:16 UTC

Description QinXie 2010-05-06 06:15:06 UTC
In old version, the minor number of RHEL version will be shown in info's output.
But in the latest one, v7-1.1-23, it's missing.
eg: for the output based on RHEL5.4, the output looks like belowing:
<snip>
.......
Tested OS: Red Hat Enterprise Linux Server 5 (Tikanga)
Kernel RPM: kernel-xen-2.6.18-164.el5
v7 version 1.1, release 23
......
</snip>

Wish the minor version number of RHEL can be put back.

Comment 1 Greg Nichols 2011-01-20 21:42:42 UTC
Created attachment 474551 [details]
info test patch to show minor version if present

Comment 5 Caspar Zhang 2011-04-30 07:50:16 UTC
Running ./info.py:
Tested OS: Red Hat Enterprise Linux Workstation 6 (Santiago)
Kernel RPM: kernel-2.6.32-131.0.5.el6
v7 version 1.2, release 25

Comment 6 Caspar Zhang 2011-04-30 07:50:16 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
in v7-1.2, a regression occured that info test only printed the major version of RHEL. Now info test prints both major and minor version information.

Comment 7 Caspar Zhang 2011-04-30 08:16:50 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-in v7-1.2, a regression occured that info test only printed the major version of RHEL. Now info test prints both major and minor version information.+In v7-1.2, a regression occured that info test only printed the major version of RHEL. This issue has been fixed in v7-1.3, now v7 prints both major and minor version information in info test.

Comment 8 Caspar Zhang 2011-04-30 08:19:35 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-In v7-1.2, a regression occured that info test only printed the major version of RHEL. This issue has been fixed in v7-1.3, now v7 prints both major and minor version information in info test.+In v7 1.2, a regression occured that info test only printed the major version of RHEL. This issue has been fixed in v7 1.3, now v7 prints both major and minor version information in info test.

Comment 9 errata-xmlrpc 2011-05-09 16:15:23 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0497.html


Note You need to log in before you can comment on or make changes to this bug.