Bug 589432 - [RFE] rpmlint could warn about the syntax problems in man-pages
[RFE] rpmlint could warn about the syntax problems in man-pages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 02:55 EDT by Ivana Varekova
Modified: 2010-06-04 14:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: rpmlint-0.97-1.fc13
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 16:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivana Varekova 2010-05-06 02:55:57 EDT
Description of problem:
From f14 there is new version of groff (1.20) and new version of man pages reader man-db package which is able to produce the list of bugs in syntax for given man-page. 

e.g. 
$ man --warnings /usr/share/man/man1/gm.1.gz >/dev/null 
<standard input>:1301: warning: macro `unsigned'' not defined
<standard input>:5345: warning: macro `-resize' not defined
<standard input>:5347: warning: macro `+profile' not defined

This could be automatically tested in rpmlint.
Comment 1 Ville Skyttä 2010-05-06 03:32:38 EDT
Can this be tested in a backwards compatible manner, for example directly with groff?  man --warnings cannot be used with man 1.6f.
Comment 2 Ville Skyttä 2010-05-06 03:34:56 EDT
To clarify, backwards compatible manner doesn't necessarily have to mean that the tests would produce warnings with some earlier versions of man/groff (they could just fail silently), but it'd be nice to not have to introduce a config parameter to turn this feature on/off.
Comment 3 Ivana Varekova 2010-05-06 06:12:47 EDT
There seems to be a way how to use groff directly (nroff in groff 1.18 can't be used).
Comment 4 Ville Skyttä 2010-05-06 08:10:00 EDT
Sounds good, could you post the info how to do it directly with groff here when you find it out?
Comment 5 Ivana Varekova 2010-05-10 08:36:32 EDT
eg. if you want to check man page: 
/usr/share/man/man1/bash.1.gz
you can use command
/usr/bin/gunzip -c '/usr/share/man/man1/bash.1.gz' | /usr/bin/gtbl | groff -mtty-char -Tutf8 -P-c -mandoc -mandoc -wmac  >/dev/null
output the same level of warnings as 
man --warnings bash
Comment 6 Ville Skyttä 2010-05-17 15:45:59 EDT
Done upstream, will most likely be in the next release:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1780
Comment 7 Fedora Update System 2010-05-18 16:20:38 EDT
rpmlint-0.97-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/rpmlint-0.97-1.fc13
Comment 8 Fedora Update System 2010-05-18 16:21:53 EDT
rpmlint-0.97-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.97-1.fc12
Comment 9 Fedora Update System 2010-05-28 14:03:29 EDT
rpmlint-0.97-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-06-04 14:46:33 EDT
rpmlint-0.97-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.