Bug 589453 - some nwfilter related functions missing in libvirt-python bindings
some nwfilter related functions missing in libvirt-python bindings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
: 589050 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 04:13 EDT by Gunannan Ren
Modified: 2014-06-18 03:18 EDT (History)
9 users (show)

See Also:
Fixed In Version: libvirt-0.8.1-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:33:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gunannan Ren 2010-05-06 04:13:21 EDT
Description of problem:
on the version libvirt-python-0.8.1-1.el6.x86_64
There are some functions not to be included in libvirt.py for nwfilter feature.
like nwfilterLookupByUUIDString, nwfilterDefineXML , nwfilter-undefined function
nwfilter-dumpxml function

Version-Release number of selected component (if applicable):

libvirt-python-0.8.1-1.el6.x86_64

How reproducible:

always

Steps to Reproduce:
1.look up the libvirt.py
2.
3.
  
Actual results:

lack of some nwfilter related functions

Expected results:

all nwfilter related functions exists

Additional info:
Comment 2 RHEL Product and Program Management 2010-05-06 05:36:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Daniel Berrange 2010-05-11 06:53:46 EDT
This should be addressed by this commit that was in 0.8.1

commit f7366d84f4c83c50e79f3f24cc038e0a1c83374b
Author: Stefan Berger <stefanb@us.ibm.com>
Date:   Thu Apr 29 06:46:01 2010 -0400

    nwfilter: python bindings for nwfilter
    
    I have primarily followed the pattern of the 'secret' driver to provide
    support for the missing python bindings for the network filter API.



and in my GIT checkout everything is fine. It looks like the tar.gz of the 0.8.1 release of libvirt though included an outdated docs/libvirt-api.xml file and thus when the python bindings got built in brew, these APIs were not included. We need to find out why the libvirt-api.xml was not being re-generated correctly. Forcing regeneration in brew & rebuilding shoudl fix this.
Comment 5 Daniel Veillard 2010-05-11 09:27:56 EDT
Argh, that's the reason ... okay, will fix, thanks !

Daniel
Comment 6 Stefan Berger 2010-05-11 09:52:39 EDT
Confirmed that in 2nd build

libvirt-python-0.8.1-2.el6.x86_64

parts of the API are also missing and docs/libvirt-api.xml does not show
the nwfilter functions. The git checkout of tag v0.8.1 does show the functions in docs/libvirt-api.xml.
Comment 7 Daniel Veillard 2010-05-12 12:30:18 EDT
libvirt-0.8.1-3.el6 has been built in RHEL-6-candidate with the fix, it should
now export the nwfilter functions and snapshot ones from python bindings.

The problem is precisely that docs/libvirt-api.xml is not in git anymore
and the docs/Makefile.am was modified in subtle ways leading to it
not being rebuilt anymore on "make dist" like I'm used to.

Daniel
Comment 8 Stefan Berger 2010-05-14 14:38:51 EDT
I installed libvirt-0.8.1-3.el6 rpm and can confirm that the previously missing functions are now available in the python bindings.
Comment 9 Daniel Berrange 2010-05-18 12:53:10 EDT
*** Bug 589050 has been marked as a duplicate of this bug. ***
Comment 12 releng-rhel@redhat.com 2010-07-02 15:33:08 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.