Bug 58951 - xfs errors about unknown tokens after upgrading XFree86
Summary: xfs errors about unknown tokens after upgrading XFree86
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-28 14:53 UTC by Jonathan Kamens
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 05:00:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2002-01-28 14:53:11 UTC
After upgrading to the current Raw Hide XFree86 packages and rebootings, I got a
bunch of errors on my console during reboot when xfs started up, about
unrecognized tokens in files in /usr/X11R6/lib/X11/fonts/encodings/large.  Alas,
I could not capture them because they were sent to stderr instead of the boot
log, and I cannot duplicate the problem now, so I don't know exactly which part
of the xfs startup is causing it.  Also, when I rebooted a second time the
errors did not recur.

Comment 1 Mike A. Harris 2002-01-30 14:58:03 UTC
Hmm.  Unable to produce so far..  It's important with rawhide bug reports
to indicate the exact version-release of the package you're reporting
the bug for, and in upgrade failure cases, to also report the ver-rel of
the package that was being upgrade.

If you could paste a log or something of the errors, it might be useful
to track down any problem.

Comment 2 Jonathan Kamens 2002-01-30 15:21:14 UTC
It's difficult for me to provide a log because the problem happens at reboot. 
But the next time I update XFree86 I'll restart xfs by hand in a script shell
and see if I can duplicate it there.

The problem happened with two Raw Hide XFree86 updates in a row -- it wasn't
confined to a single Raw Hide version.


Comment 3 Jonathan Kamens 2002-01-31 03:06:43 UTC
I just upgraded to all the 4.2.0-3.2 packages and ran "service xfs start" inside
a script shell:

Script started on Wed Jan 30 22:02:58 2002
[root@jik fs]# service xfs start
Starting xfs: unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token 0x84 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token 0x31 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token 0xA0 in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token 0x40 in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1990-0.enc.gz, line 5
unexpected token 0x20 in file
/usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1990-0.enc.gz, line 5
unexpected token 0x20 in file
/usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1990-0.enc.gz, line 5
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token 0xA0 in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token 0x40 in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1983-0.enc.gz, line 3
unexpected token 0x20 in file
/usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1983-0.enc.gz, line 3
unexpected token 0x20 in file
/usr/X11R6/lib/X11/fonts/encodings/large/jisx0208.1983-0.enc.gz, line 3
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token 0xA0 in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token 0x40 in file
/usr/X11R6/lib/X11/fonts/encodings/large/big5.eten-0.enc.gz, line 7
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1987-0.enc.gz, line 5
unexpected token 0x20 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1987-0.enc.gz, line 5
unexpected token 0x20 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1987-0.enc.gz, line 5
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token 0x84 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token 0x31 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token FIRSTINDEX in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token 0x84 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
unexpected token 0x31 in file
/usr/X11R6/lib/X11/fonts/encodings/large/ksc5601.1992-3.enc.gz, line 8
[60G[  [1;32mOK[0;39m  ]
[root@jik fs]# exit
exit

Script done on Wed Jan 30 22:03:07 2002


Comment 4 Mike A. Harris 2002-05-18 00:34:49 UTC
Problem should be fixed in Red Hat Linux 7.3 final release.


Note You need to log in before you can comment on or make changes to this bug.