Bug 589510 - [RFE] GFS2: Add method to discover whether the lock dropping interface has been used
[RFE] GFS2: Add method to discover whether the lock dropping interface has be...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Steve Whitehouse
Cluster QE
: FutureFeature
Depends On: 577900
Blocks: 534147
  Show dependency treegraph
 
Reported: 2010-05-06 06:46 EDT by Steve Whitehouse
Modified: 2016-04-26 09:33 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 577900
Environment:
Last Closed: 2010-11-11 11:18:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL6 version of the patch (1.54 KB, patch)
2010-05-14 09:59 EDT, Steve Whitehouse
no flags Details | Diff

  None (edit)
Description Steve Whitehouse 2010-05-06 06:46:49 EDT
+++ This bug was initially created as a clone of Bug #577900 +++

Description of problem:

Since the lock dropping interface via /sysfs is dangerous in the sense that it can result in file system corruption if misused, we need to add some way to tell if someone has used this particular interface.

--- Additional comment from swhiteho@redhat.com on 2010-04-30 10:43:38 EDT ---

We could do this with an sb flag. Then the info could appear both in /proc/mounts and also as a (one time) log message. That should make it easy to spot.

At the same time we'll add a log message to let people know when barriers have been turned off automatically as well.

--- Additional comment from swhiteho@redhat.com on 2010-04-30 11:09:02 EDT ---

Created an attachment (id=410510)
Proposed patch

--- Additional comment from swhiteho@redhat.com on 2010-05-06 06:20:25 EDT ---

Posted to cluster-devel.
Comment 1 Steve Whitehouse 2010-05-06 06:47:32 EDT
Cloned for RHEL6.
Comment 2 RHEL Product and Program Management 2010-05-06 06:51:06 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.
Comment 4 Steve Whitehouse 2010-05-14 09:59:45 EDT
Created attachment 414058 [details]
RHEL6 version of the patch
Comment 5 Aristeu Rozanski 2010-05-28 16:37:39 EDT
Patch(es) available on kernel-2.6.32-31.el6
Comment 8 Nate Straz 2010-10-07 10:03:05 EDT
[root@buzz-02 buzzez:buzzez0]# echo "5:42379 EX" > /sys/fs/gfs2/buzzez\:buzzez0/demote_rq

GFS2: fsid=buzzez:buzzez0.1: demote interface used

[root@buzz-02 buzzez:buzzez0]# grep buzzez /proc/mounts
/dev/dm-3 /mnt/buzzez0 gfs2 rw,seclabel,relatime,hostdata=jid=1,demote_interface_used 0 0
Comment 9 releng-rhel@redhat.com 2010-11-11 11:18:40 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.