Bug 589523 - warnquota does not support NFS shares
Summary: warnquota does not support NFS shares
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: quota
Version: 5.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Petr Pisar
QA Contact: Martin Cermak
URL:
Whiteboard:
: 589531 (view as bug list)
Depends On: 395301
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 11:18 UTC by Petr Pisar
Modified: 2018-10-24 10:20 UTC (History)
5 users (show)

Fixed In Version: quota-3.13-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of: 395301
Environment:
Last Closed: 2011-01-13 22:10:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0023 normal SHIPPED_LIVE quota bug fix and enhancement update 2011-01-12 15:59:31 UTC

Description Petr Pisar 2010-05-06 11:18:55 UTC
+++ This bug was initially created as a clone of Bug #395301 +++

From the warnquota man page:
warnquota checks the disk quota for each filesystem and mails a warning message
 to  those users who have reached their softlimit.

This however does not work for nfs based mounts using quotas. This was reported
  by a customer.

The support for NFS is disabled in the warnquota code. To confirm this, I posted
a note to the forum on the quota sourceforge.net page and got the confirmation
that it is not supported over NFS and no plans exist currently to add support.
http://sourceforge.net/forum/forum.php?thread_id=1870399&forum_id=57476

A change instead was made to the warnquota man page to make it clear that
warnquota works only for local filesystems.

http://linuxquota.cvs.sourceforge.net/linuxquota/quota-tools/warnquota.8?r1=1.9&r2=1.10

Can engineering please change the man page to make it clear that the warnquota
utility only works for local filesystems.

--- Additional comment from ovasik@redhat.com on 2010-03-19 10:30:02 EDT ---

easyfix, just manpage change/clarification.

Comment 1 Petr Pisar 2010-05-06 12:16:21 UTC
*** Bug 589531 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2011-01-13 22:10:38 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0023.html


Note You need to log in before you can comment on or make changes to this bug.