Bug 589552 - incremental archives with stored ACLs
incremental archives with stored ACLs
Status: CLOSED DUPLICATE of bug 555391
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tar (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 08:41 EDT by guybrush
Modified: 2010-05-06 09:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 09:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guybrush 2010-05-06 08:41:37 EDT
Description of problem:
Currently it's impossible to create incremental archive with ACLs stored.

tar -c --acls --listed-incremental=1.star -f 1.tar.gz <files>
fails with 
tar: GNU features wanted on incompatible archive format
Try `tar --help' or `tar --usage' for more information.

Seems http://git.savannah.gnu.org/cgit/tar.git/commit/?id=f865597c8963ef23f4c2c9d0f58334d03a9c5305

fixed it.
Comment 1 Ondrej Vasik 2010-05-06 09:45:21 EDT
Thanks for report/future feature request.
Not only that commit - that's only part of the more upstream commits (that's the final one) to support several gnu options in POSIX format ... Changes are too invasive for RHEL-5.
This was once requested in https://bugzilla.redhat.com/show_bug.cgi?id=555391 . http://git.savannah.gnu.org/cgit/tar.git/commit/?id=aea1d50da919e8649e6eb7ae849db2511e3636f1  , http://git.savannah.gnu.org/cgit/tar.git/commit/?id=f6458a827ae7a2c41616490f653714068072b257 and probably more commits are necessary to prevent reports of invalid functionality of listed-incremental options in POSIX format in RHEL-5. Closing WONTFIX, if you really need these GNU features with --acls options (in POSIX tar format), please contact product support at www.redhat.com/support - as backporting all the changes to support these options in POSIX format would need a bit of time and extensive testing.
Closing DUPLICATE of 555391.

*** This bug has been marked as a duplicate of bug 555391 ***

Note You need to log in before you can comment on or make changes to this bug.