Bug 589599 - error when unmounting drive in nautilus
Summary: error when unmounting drive in nautilus
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 14:20 UTC by Máirín Duffy
Modified: 2015-03-03 22:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-21 16:14:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the error (954.19 KB, image/png)
2010-05-06 14:20 UTC, Máirín Duffy
no flags Details

Description Máirín Duffy 2010-05-06 14:20:08 UTC
Created attachment 412070 [details]
screenshot of the error

Description of problem:

I'm using rhel 6 beta++. I have a 500GB external hard drive I had plugged in to my rhel 6 laptop. I tried to unmount it ('safely remove device' is the option I used) and I got the following error:

"Unable to stop drive: Error detaching: helper exited with code 1: Incorrect usage"

It sees like it unmounted the device anyway though. I plugged it out and it seemed fine. I have mounted and ejected the drive at least two times successfully since I got the error, but I thought the bug might be worth filing anyway.


Version-Release number of selected component (if applicable):
nautilus-2.28.4-9.el6.x86_64
hal-0.5.14-2.el6.x86_64
14-2.el6.x86_64

How reproducible:

Not very. It hasn't happened since.

Comment 2 RHEL Product and Program Management 2010-05-06 16:09:13 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Tomáš Bžatek 2010-05-20 14:55:34 UTC
Works fine here with a USB stick. This would be hard to debug, any chance to grab a 'ps axlf' output when the error appears? (most probably the failing process will be gone already)

gvfs-1.4.3-8.el6.x86_64
udisks-1.0.1-1.el6.x86_64
gnome-disk-utility-2.30.1-2.el6.x86_64

Comment 4 RHEL Product and Program Management 2010-07-15 14:19:52 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 5 Tomáš Bžatek 2011-01-21 16:14:10 UTC
I'm going to close this bugreport for the moment, please reopen if you hit this problem again.


Note You need to log in before you can comment on or make changes to this bug.