This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 58973 - iptables errors
iptables errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 15:09 EST by Jaroslaw Sosnicki
Modified: 2015-01-04 17:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 22:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 2002-01-28 15:09:38 EST
Description of Problem:
When enabling firewall rules I am getting the folowing error:
iptables: libiptc/libip4tc.c:386: do_check: Assertion `h->info.valid_hooks == (1
<< 0 | 1 << 3)' failed.

Version-Release number of selected component (if applicable):
kernel-2.4.17-0.9smp
iptables-1.2.5-1

see attached file for all installed components

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-01-28 17:41:57 EST
Which rules are you trying to use? Can't reproduce it with my firewall rules.
Comment 2 Jaroslaw Sosnicki 2002-01-28 19:43:49 EST
Try:
iptables -t mangle -F

above command works with iptables-1.2.4-2 and kernel-2.4.17-0.1bigmem
Comment 3 Bernhard Rosenkraenzer 2002-01-31 09:39:03 EST
I can reproduce the problem on a rawhide system, but not on a 7.2+errata 
system with just the iptables package upgraded. 
 
Apparently the new kernel modules are supplying wrong information.
Comment 4 Arjan van de Ven 2002-01-31 09:41:07 EST
iptables is b0rked in rawhide kernels right now; will be fixed once 2.4.18pre8
comes out...

Note You need to log in before you can comment on or make changes to this bug.