This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 5898 - Wrong mode/owner of some files
Wrong mode/owner of some files
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: samba (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-12 17:29 EDT by Enrico Scholz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-01 14:33:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 1999-10-12 17:29:04 EDT
* I am missing a %defattr(-,root,root) in the filelist of
the common packet.

* The smbd manpage recommends a logfile-directory readable
only by root. Currently the mode is 0755.
Comment 1 Bill Nottingham 1999-10-29 16:31:59 EDT
The %defattr is fixed in samba-2.0.5a-15, which will be in
the next Raw Hide release.

I would think that it would be better to make the log *files*
not world readable, as opposed to the directory. (or possibly
both.)
Comment 2 Bill Nottingham 1999-12-01 14:33:59 EST
Actually, since the log file names contain client names, they
could be sensitive, I suppose.

Fixed in samba-2.0.6-2, which will be in the next Raw Hide release.

Note You need to log in before you can comment on or make changes to this bug.