Bug 589895 - fcgi-perl with perl-5.12.0
fcgi-perl with perl-5.12.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fcgi (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
:
Depends On: perl-FCGI
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 04:46 EDT by Marcela Mašláňová
Modified: 2010-07-15 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 05:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2010-05-07 04:46:29 EDT
I prepared test buildroot for new release of perl. It seems to me that in your sub-package fcgi-perl are some deprecated calls. 

Warning from perl-SOAP-Lite build:

defined(%hash) is deprecated at /usr/lib/perl5/FCGI.pm line 35 (#1)
    (D deprecated) defined() is not usually useful on hashes because it
    checks for an undefined scalar value.  If you want to see if the hash
    is empty, just use if (%hash) { # not empty } for example.

        (Maybe you should just omit the defined()?)
defined(%hash) is deprecated at /usr/lib/perl5/FCGI.pm line 54 (#1)
        (Maybe you should just omit the defined()?)

These problems should be easy to fix, but I'd rather leave it to you or upstream.
Comment 1 Chris Weyl 2010-05-07 15:57:33 EDT
We've also seen development in the last several months to the FCGI package hosted on the CPAN.  While 0.67 (last updated in 2002) is AFAICT the same as the FCGI package provided by fcgi, I'm not sure the recent work is in sync with FCGI here anymore.  0.70 && 0.71 were both releases specifically targeting the perl 5.12 introduced depreciation reported here.

If there's a correspondingly new fcgi package, we should probably update the whole kit.  ...but if there is, I can't find it; and it doesn't look like the CPAN-generated diff[1] from 0.67 to 0.71 applies cleanly to the fcgi source perl/ directory.

It might be time to package perl-FCGI from 0.71 on the CPAN, and have it provide/obsolete fcgi-perl.  Comments? :)

[1] http://search.cpan.org/diff/FCGI-0.67-FCGI-0.71.-w.diff
Comment 2 Chris Weyl 2010-05-16 00:48:04 EDT
So, perl-FCGI 0.71 is in rawhide (well, dist-f14-perltest), and F-13/12 testing.  I'll let it sit in testing for a couple weeks, then go in and remove the underlying -perl subpackage bits from fcgi so we're not always building an obsolete-when-built fcgi-perl.

If fcgi development becomes active again and consumes FCGI, I don't have a problem reversing this (that is, restoring the subpackage and having it obsolete the standalone package).

Sound good?  :)

Note You need to log in before you can comment on or make changes to this bug.