Bug 58992 - scp does not like colons
Summary: scp does not like colons
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2002-01-28 23:31 UTC by Michal Jaegermann
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-03 10:04:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Michal Jaegermann 2002-01-28 23:31:31 UTC
Description of Problem:

'scp' refuses to handle files with ':' in their names.  No matter what
quoting and escaping I tried it was getting really confused.  The only
workaround if I want to keep names, time stamps and/or permits which came
to mind was to use tar, or similar, to stdout, and pass resulting stream
through ssh to an extracting tar on the other end.  Seeing my wife to do
that would be interesting. :-)

Smells like a "generic" bug in arguments handling by 'scp' not mentioned
on its manpage.

Comment 1 Zing 2002-01-29 19:18:13 UTC
try a "./" before the filename.  ex.

scp ./blah:blah server:
scp server:./blah:blah backhome

Comment 2 Michal Jaegermann 2002-01-29 22:24:32 UTC
Yes, indeed both 'scp ./blah:bla.txt ...' and 'scp ./blah\:bla.txt ...'
worked as intended.  After other quoting attempts failed this trick did
not come to my mind. :-)

Comment 3 Tomas Mraz 2005-02-03 10:04:17 UTC
The workaround works. Otherwise try reporting upstream.

Note You need to log in before you can comment on or make changes to this bug.