Bug 589930 - RHEL6 kernel fails to boot with 3585-3709MB of memory
RHEL6 kernel fails to boot with 3585-3709MB of memory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
All Linux
low Severity high
: rc
: ---
Assigned To: Larry Woodman
Virtualization Bugs
:
Depends On:
Blocks: 562808 846704 1270638
  Show dependency treegraph
 
Reported: 2010-05-07 06:27 EDT by Jes Sorensen
Modified: 2015-10-28 06:54 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-28 06:54:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lwoodman: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2010-05-07 06:27:40 EDT
Description of problem:
When trying to boot a pre-installed RHEL6 guest on RHEL6, setting the guest memory to a size between 3585MB and 3710MB, it hangs during boot.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.48.el6.x86_64
kernel-2.6.32-23.el6.x86_64
seabios-0.5.1-0.7.20100108git669c991.el6.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install RHEL6 guest on RHEL6 host
2. Increase guest memory to between 3585MB and 3709MB
3. Boot it
  
Actual results:
Hangs during boot

Expected results:


Additional info:
I verified it on my test system and DV is seeing similar behaviour on one of his test systems.

I am guessing this is related to qemu-kvm or SeaBIOS not reserving the block of memory correctly when it is within this range. However it is unclear at this point whether this is a qemu-kvm, seabios or even kernel bug.
Comment 2 Jes Sorensen 2010-05-07 06:31:26 EDT
I suspect this bug is related to https://bugzilla.redhat.com/show_bug.cgi?id=561290
Comment 3 Daniel Veillard 2010-05-07 06:31:52 EDT
I could reproduce this on my own hardware with same components:

[root@test2 ~]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.48.el6.x86_64
[root@test2 ~]# rpm -q kernel
kernel-2.6.32-23.el6.x86_64
[root@test2 ~]# uname -a
Linux test2 2.6.32-23.el6.x86_64 #1 SMP Tue Apr 27 21:17:28 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@test2 ~]# rpm -q seabios
seabios-0.5.1-0.3.20100108git669c991.el6.x86_64
[root@test2 ~]# 

Daniel
Comment 4 RHEL Product and Program Management 2010-05-07 07:31:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Don Dutile 2010-05-07 14:20:52 EDT
I tested a seabios patch for 561290,
and with that seabios, I could not duplicate this error
using a RHEL5-164 guest, and a rhel6/2.6.32-15 kernel;
qemu-kvm: 0.12.1.2-2.15.

I was working off the tip of seabios, which was same as above version.
so, that clears (the patched for better dmidecode) seabios; could be qemu or guest kernel problem...
Comment 6 Jes Sorensen 2010-05-10 01:57:06 EDT
Don,

I am not sure I follow you. Are you saying the Seabios patch made the problem go away or were you not able to reproduce it prior to the Seabios patch either?

FWIW I only saw this problem when trying to boot RHEL6 guests, not with RHEL5 ones. But that may be due to a memory layout problem so it doesn't show.

Cheers,
Jes
Comment 7 Jes Sorensen 2010-05-17 07:27:58 EDT
Hi,

With more testing I found that this is can in fact be reproduced on real hardware, by specifying an appropriate limit using the memmap= option. So reassigning it to the kernel component.

On a system with less than ~11GB of RAM, the following boot time argument should show the problem:

memmap=8G$0x100044000

With more memory, just increase the '8G' to something higher.

This happens both with upstream and the RHEL6 kernel.

Jes
Comment 8 Jes Sorensen 2010-05-17 15:22:15 EDT
Update bug title - forgot earlier when updated component
Comment 10 Jes Sorensen 2010-07-20 05:04:02 EDT
Moving to 6.1.

Jes
Comment 13 RHEL Product and Program Management 2011-01-06 22:54:06 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 14 Suzanne Yeghiayan 2011-01-07 11:15:25 EST
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.
Comment 15 RHEL Product and Program Management 2011-02-01 00:31:41 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 16 RHEL Product and Program Management 2011-02-01 13:19:39 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 17 RHEL Product and Program Management 2011-04-03 22:18:29 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 18 RHEL Product and Program Management 2011-10-07 11:02:11 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 19 Larry Woodman 2015-10-14 10:25:46 EDT
Can someone test the latest RHEL6 kernel and see if this is still a problem?  There have been several changes to the RHEL6 memory initialization code that probably fixed this problem.

Larry
Comment 20 Chao Yang 2015-10-27 23:05:40 EDT
(In reply to Larry Woodman from comment #19)
> Can someone test the latest RHEL6 kernel and see if this is still a problem?
> There have been several changes to the RHEL6 memory initialization code that
> probably fixed this problem.
> 
> Larry

Sorry for the late response. Qianqian will give an update soon.
Comment 21 Qianqian Zhu 2015-10-28 05:39:44 EDT
(In reply to Larry Woodman from comment #19)
> Can someone test the latest RHEL6 kernel and see if this is still a problem?
> There have been several changes to the RHEL6 memory initialization code that
> probably fixed this problem.
> 
> Larry

Reproduced with:
Red Hat Enterprise Linux Server release 6.7
kernel-2.6.32-573.el6.x86_64
qemu-kvm-0.12.1.2-2.481.el6.x86_64
seabios-0.6.1.2-30.el6.x86_64

Steps:
1. Install RHEL6.7 guest on RHEL6.7 host
2. Start guest with memory 3585MB/3586MB/3608MB/3708MB/3709MB separately
3. Boot it
  
Actual results:
Guest boot successfully.
Comment 22 Qianqian Zhu 2015-10-28 06:43:49 EDT
Sorry, made mistakes here, make corrections as below:

(In reply to qianqianzhu from comment #21)
> (In reply to Larry Woodman from comment #19)
> > Can someone test the latest RHEL6 kernel and see if this is still a problem?
> > There have been several changes to the RHEL6 memory initialization code that
> > probably fixed this problem.
> > 
> > Larry
> 

Tested with:
Red Hat Enterprise Linux Server release 6.7
kernel-2.6.32-583.el6.x86_64
qemu-kvm-0.12.1.2-2.481.el6.x86_64
seabios-0.6.1.2-30.el6.x86_64

Steps:
1. Install RHEL6.7 guest on RHEL6.7 host
2. Start guest with memory 3585MB/3586MB/3608MB/3708MB/3709MB separately
3. Boot it
   
Actual results:
Guest boot successfully.

Note You need to log in before you can comment on or make changes to this bug.