Bug 589965 - oops in e1000_vlan_rx_kill_vid()
oops in e1000_vlan_rx_kill_vid()
Status: CLOSED DUPLICATE of bug 546740
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 08:21 EDT by Vasily Averin
Modified: 2010-05-07 08:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 08:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasily Averin 2010-05-07 08:21:28 EDT
Description of problem:

crash because of incorrect backport of vlan_group_set_device() function:
implementation in compat headers do not checks first argument.
   drivers/net/e1000e/e1000_compat.h
   drivers/net/igb/igb_compat.h

Dear Andy,
Parallels/OpenVZ support team got bugreport with screenshot that shows oops in e1000_vlan_rx_kill_vid() in e1000e driver.

I've processed it and found following:
kernel was crashed inside
e1000_vlan_rx_kill_vid()
 vlan_group_set_device()

because of adapter->vlgrp was NULL.

IMHO it's possible for example when e1000_vlan_rx_kill_vid() is called from
 e1000_close() or from e1000_vlan_rx_register()

It happens because of backport of vlan_group_set_device() function does not check first argument.

Similar issue exists at least in igb driver too, when igb_vlan_rx_kill_vid() is called from igb_close() or from igb_vlan_rx_register()

Unfortunately I cannot provide clear error messages: I have only partially saved messages on screenshot. Also I was unable to reproduce issue locally.
On the other hand according to reporter it's reproducible issue. We're trying to get full oops messages and reproducer from him, and will update this bug when we'll got it.
Comment 1 Vasily Averin 2010-05-07 08:25:38 EDT
IMHO issue exists in2.6.18-194.el5 and .198.el5 RHEL5 kernels
Comment 2 Andy Gospodarek 2010-05-07 08:50:35 EDT
Thanks, Vasily.  We have plans to remove all of the *compat.h files in the network driver tree during this update cycle, so I hope to have all of these issues fixed in RHEL5.6.
Comment 3 Andy Gospodarek 2010-05-07 08:51:12 EDT

*** This bug has been marked as a duplicate of bug 546740 ***

Note You need to log in before you can comment on or make changes to this bug.