Bug 589978 - libvirt needs to use netdev_add for NIC hotplug
libvirt needs to use netdev_add for NIC hotplug
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On: 559670
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 08:51 EDT by Daniel Berrange
Modified: 2010-07-02 15:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: libvirt-0.8.1-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2010-05-07 08:51:17 EDT
Description of problem:
When booting guests, libvirt uses -netdev for setting up host networking. When doing NIC hotplug though, it uses host_net_add. This is bad because host_net_add is a different form of networking with performance limitations. NIC hotplug needs to be changed to use netdev_add


Version-Release number of selected component (if applicable):
libvirt-0.8.1

How reproducible:
Always

Steps to Reproduce:
1. Attempt to hotplug a NIC
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2010-05-07 08:58:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Daniel Veillard 2010-05-07 12:30:09 EDT
libvirt-0.8.1-2.el6 has been built in RHEL-6-candidate with the patch

Daniel
Comment 7 releng-rhel@redhat.com 2010-07-02 15:33:14 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.