Bug 589999 - Network mapping in virt-v2v.conf are not parsed
Summary: Network mapping in virt-v2v.conf are not parsed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 589929 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 13:35 UTC by Nan Zhang
Modified: 2010-11-09 13:21 UTC (History)
8 users (show)

Fixed In Version: 0.5.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-16 16:18:33 UTC


Attachments (Terms of Use)
virt-v2v-0.5.3 config file (3.59 KB, text/plain)
2010-05-11 07:07 UTC, Nan Zhang
no flags Details

Description Nan Zhang 2010-05-07 13:35:41 UTC
Description of problem:
the converted PV and FV guest from Xen can't be started up.

Version-Release number of selected component (if applicable):
v2v-libvirt-0.8.1-1.el5
virt-v2v-0.5.3-1.el5

How reproducible:
Always

Steps to Reproduce:
# virt-v2v -f /usr/share/doc/virt-v2v-0.5.3/virt-v2v.conf -i libvirtxml -op v2v-test rhel5u5-64b-pv-raw-intel.xml
virt-v2v: WARNING: No mapping found for bridge interface xenbr0 in config file. The converted guest may not start until its network interface is updated.
virt-v2v: rhel5u5-64b-pv-raw-intel configured with virtio drivers

# virsh start rhel5u5-64b-pv-raw-intel
error: Failed to start domain rhel5u5-64b-pv-raw-intel
error: internal error Failed to add tap interface 'vnet%d' to bridge 'xenbr0' : No such device
  
Actual results:
The converted guest can't be started.

Expected results:
The converted guest can be started.

Additional info:
Also failed to start the following converted guest.
rhel3u9 i386/x86_64
rhel4u8 i386/x86_64
rhel5u4 i386/x86_64
rhel5u5 i386/x86_64

Comment 1 Nan Zhang 2010-05-10 07:23:47 UTC
I found the Xen interface was not replaced with KVM network config in libvirt guest xml.

    <interface type='bridge'>
      <mac address='00:16:36:53:e5:69'/>
      <source bridge='xenbr0'/>
      <model type='virtio'/>
    </interface>

Comment 2 Nan Zhang 2010-05-10 08:25:28 UTC
Guest rhel5u4-64b-pv-raw-intel:

    <interface type='bridge'>
      <mac address='00:16:36:23:30:86'/>
      <source bridge='xenbr0'/>
      <target dev='vnet%d'/>
      <model type='virtio'/>
    </interface>

Comment 3 Nan Zhang 2010-05-10 09:12:16 UTC
The converted image from ESX3.5 also failed.

# virt-v2v -f /usr/share/doc/virt-v2v-0.5.3/virt-v2v.conf -ic esx://10.66.91.46/?no_verify=1 -op v2v-test ESX3.5-RHEL5.5-i386
virt-v2v: WARNING: No mapping found for bridge interface VM Network in config file. The converted guest may not start until its network interface is updated.
virt-v2v: ESX3.5-RHEL5.5-i386 configured with virtio drivers

# virsh start ESX3.5-RHEL5.5-i386
error: Failed to start domain ESX3.5-RHEL5.5-i386
error: internal error Failed to add tap interface 'vnet%d' to bridge 'VM Network' : No such device

Guest interface XML description:

    <interface type='bridge'>
      <mac address='00:0c:29:b8:b6:c1'/>
      <source bridge='VM Network'/>
      <target dev='vnet%d'/>
      <model type='virtio'/>
    </interface>

Comment 4 Matthew Booth 2010-05-10 16:04:52 UTC
Can you attach the contents of /usr/share/doc/virt-v2v-0.5.3/virt-v2v.conf? I suspect that this file hasn't been updated, and therefore doesn't contain a network mapping (hence the warning). If this is the case, then the above is expected behaviour.

Note that you can now also specify a default network mapping on the command line, e.g.:

# virt-v2v --network default -ic
esx://10.66.91.46/?no_verify=1 -op v2v-test ESX3.5-RHEL5.5-i386

Comment 5 Nan Zhang 2010-05-11 07:07:52 UTC
Created attachment 413053 [details]
virt-v2v-0.5.3 config file

Matt,

When I encountered this error, I also suspected the config file wasn't updated. But actually the network mapping was uncommented by me. I don't know why? 

I try to specify a default network mapping via command line, it can be successfully converted and booted.

Thanks,
Neil

Comment 6 Matthew Booth 2010-05-11 14:11:45 UTC
Sorry it has taken me so long to get the bottom of this one. It was actually caused by a bug in the configuration parser which was triggered only by the version of perl in RHEL 5. The effect of this bug is that, on RHEL 5, network mappings in the config file will never be matched.

Patch is now upstream here:
http://git.fedorahosted.org/git/?p=virt-v2v.git;a=commitdiff;h=HEAD

Comment 7 Matthew Booth 2010-05-11 14:12:37 UTC
*** Bug 589929 has been marked as a duplicate of this bug. ***

Comment 8 Matthew Booth 2010-05-14 17:09:34 UTC
Fixed in 0.5.4

Comment 9 Nan Zhang 2010-05-17 10:05:58 UTC
Verified with virt-v2v-0.5.4-1.el5, it's fixed.

Comment 10 Matthew Booth 2010-07-16 16:18:33 UTC
This was released in virt-v2v-0.6.0-6.el5


Note You need to log in before you can comment on or make changes to this bug.