Bug 59008 - redhat-config-users failing
redhat-config-users failing
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-users (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-29 01:17 EST by Jaroslaw Sosnicki
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-30 22:38:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 2002-01-29 01:17:23 EST
Description of Problem:
[root@ns1 root]# redhat-config-user
bash: redhat-config-user: command not found
[root@ns1 root]# redhat-config-users
Gtk-Message: YOU ARE USING THE DEVEL BRANCH 1.3.x OF GTK+ WHICH IS CURRENTLY
                UNDER HEAVY DEVELOPMENT AND FREQUENTLY INTRODUCES INSTABILITIES.
               if you don't know why you are getting this, you probably want to
               use the stable branch which can be retrieved from
                ftp://ftp.gtk.org/pub/gtk/v1.2/ or via CVS with
                cvs checkout -r glib-1-2 glib; cvs checkout -r gtk-1-2 gtk+
Fatal Python error: could not import atk
/usr/share/redhat-config-users/redhat-config-users: line 4:  1591 Aborted      
          /usr/bin/python /usr/share/redhat-config-users/redhat-config-users.py
[root@ns1 root]# 

Version-Release number of selected component (if applicable):
see attached file listing all components installed

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Brent Fox 2002-01-30 22:38:12 EST
Try upgrading/installing atk-0.8.90-2.i386.rpm from Rawhide.  What's happening
is that the Python interpreter is trying to import the atk module and it's not
working.

However, redhat-config-users is currently in flux.  I'm in the process of
porting it to gtk2, so things might not work until that is finished.  Things
should work fine if you are using Python1.5, but not if you are using Python2.2.
 This bug is related to #59041.
Comment 2 Brent Fox 2002-02-26 16:45:23 EST
Ok, I've finished the port to GTK2 and check the code into cvs.  A new build
should appear in Rawhide soon, but it will still be buggy due to some lingering
bugs in the new libuser.  Those should be worked out soon, but since libuser
isn't my package, I'm going to close this report now.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.