Bug 590095 - [RHEL6] Required upstream patches for libfc and fcoe
[RHEL6] Required upstream patches for libfc and fcoe
Status: CLOSED DUPLICATE of bug 577049
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Rob Evers
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 13:30 EDT by Linda Wang
Modified: 2010-05-11 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 11:38:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linda Wang 2010-05-07 13:30:58 EDT
Description of problem:
For testing of DCB/LLPD for FCoE, intel has requested that 
we pull the following patches in:


>     9f8f3aa [SCSI] libfc, fcoe: normalize format specifies for world wide names
>     ce8b5df [SCSI] libfc: set both precision and field with when printing FC IDs
>     63ac4bb [SCSI] libfc: bug in erroring out upon FCP_RSP_LEN_VAL in fc_fcp_resp
>     da87bfa [SCSI] fcoe, fnic, libfc: increased CDB size to 16 bytes for fcoe.
>     8ba00a4 [SCSI] fcoe: removes unused shost in fcoe_shost_config
>     0b2f74a [SCSI] libfc: fix hton24 macro to take expressions as args
>     3b719d0 [SCSI] libfc: remove unneeded variables in fc_exch_recv_req()
>     03d29bc [SCSI] fcoe: check netif operstate instead of IFF_UP & link state
>     9ee50e4 [SCSI] fcoe: reset FIP ctlr link state on disable/enable
>     593abc0 [SCSI] libfcoe: Don't fill MAC desc in FLOGI if FIP negotiated FPMA
>
>     f018b73 [SCSI] libfc, libfcoe, fcoe: use smp_processor_id() only when preempt disabled
>     b3ef990 [SCSI] libfc: Add debug statements when fc_fcp returns DID_ERROR to scsi-ml
>     5c12c41 [SCSI] libfc: fix fcp pkt recovery in fc_fcp_recv_data
>     3e22760 [SCSI] libfc: use offload EM instance again instead jumping to next EM
>     a104c84 [SCSI] libfc: fixes unnecessary seq id jump
>     cc3593d [SCSI] libfc: fix sequence-initiative WARN in fc_seq_start_next
>     4291365 [SCSI] libfcoe: eliminate unused link and last_link fields
>     50036bba [SCSI] fcoe: remove an unused variable in fcoe_recv_frame()
>     ccfc309 [SCSI] libfc: send point-to-poin FLOGI LS_ACC to assigned D_DID
>     f4568b8 [SCSI] libfc: recognize incoming FLOGI for point-to-point mode
>     7d65b0d [SCSI] fcoe: save gateway address when receiving FLOGI request
>     e49bf61 [SCSI] libfcoe: fix debug message entering non-FIP mode
>     9860eeb [SCSI] fcoe: call fcoe_ctlr_els_send even for ELS responses
>     2f2ac4a [SCSI] libfc: fix oops in point-to-point mode
>     4dc7ccf [SCSI] libfc: add definition for task attribute mask
>     a2f6a02 [SCSI] libfc: recode incoming PRLI handling
>
>     6409ea6 [SCSI] fcoe: Only rmmod fcoe.ko if there are no active connections
>
>>>>  f47dd85 [SCSI] libfcoe: Send port LKA every FIP_VN_KA_PERIOD secs.
> This one was included in snapshot 1.
>
>     b248df3 [SCSI] libfc: Don't assume response request present.
>     3b70915 [SCSI] libfc: Fix e_d_tov ns -> ms scaling factor in PLOGI response.
>     10897ae [SCSI] libfc: call ddp setup for only FCP reads to avoid accessing junk fsp pointer
>     6957177 cpumask: use modern cpumask style in drivers/scsi/fcoe/fcoe.c
>



Version-Release number of selected component (if applicable):
RHEL6.0+
Comment 3 Rob Evers 2010-05-11 11:38:53 EDT

*** This bug has been marked as a duplicate of bug 577049 ***

Note You need to log in before you can comment on or make changes to this bug.