Bug 590130 - [abrt] crash in rss-glx-0.9.1.p-2.fc12: _mesa_meta_begin: Process /usr/bin/rss-glx-drempels was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in rss-glx-0.9.1.p-2.fc12: _mesa_meta_begin: Process /usr/bin/rs...
Status: CLOSED DUPLICATE of bug 546803
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa   
(Show other bugs)
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4989d3ca1e5346c82a34953d077...
Keywords:
: 592549 595035 600241 601896 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 19:20 UTC by Sylvain Arth
Modified: 2010-06-16 23:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 23:06:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (49.28 KB, text/plain)
2010-05-07 19:20 UTC, Sylvain Arth
no flags Details

Description Sylvain Arth 2010-05-07 19:20:56 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: rss-glx-drempels -r
comment: I was away
component: rss-glx
crash_function: _mesa_meta_begin
executable: /usr/bin/rss-glx-drempels
global_uuid: 4989d3ca1e5346c82a34953d0777e1b5fe08f234
kernel: 2.6.32.11-99.fc12.i686.PAE
package: rss-glx-0.9.1.p-2.fc12
rating: 4
reason: Process /usr/bin/rss-glx-drempels was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Sylvain Arth 2010-05-07 19:20:59 UTC
Created attachment 412429 [details]
File: backtrace

Comment 2 Karel Klíč 2010-05-25 09:57:32 UTC
*** Bug 592549 has been marked as a duplicate of this bug. ***

Comment 3 Nils Philippsen 2010-05-26 12:12:00 UTC
Hmm, the offending code is this (save is 0x0 at the time of the crash):

### 8< ###
static void
_mesa_meta_begin(GLcontext *ctx, GLbitfield state)
{
   struct save_state *save = &ctx->Meta->Save;

   save->SavedState = state;
### >8 ###

I don't see how rss-glx code influences the value of the Save member of ctx->Meta, therefore I'll change the component to mesa.

Comment 4 Jeff Raber 2010-06-16 22:53:50 UTC
*** Bug 595035 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Raber 2010-06-16 22:54:12 UTC
*** Bug 600241 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Raber 2010-06-16 22:54:25 UTC
*** Bug 601896 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Raber 2010-06-16 23:06:35 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 546803 ***


Note You need to log in before you can comment on or make changes to this bug.