Bug 59022 - cups creates /etc/cups/certs/0 and /etc/cups/ppds.dat but doesn't own them
cups creates /etc/cups/certs/0 and /etc/cups/ppds.dat but doesn't own them
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-29 10:17 EST by Jonathan Kamens
Modified: 2008-02-27 06:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 06:49:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-29 10:17:15 EST
A default installation of cups creates the files /etc/cups/certs/0 and
/etc/cups/ppds.dat, but the cups RPM doesn't know that these files are owned by
cups.
Comment 1 Tim Waugh 2002-10-19 17:40:56 EDT
Also /etc/cups/lpoptions.
Comment 2 Bill Nottingham 2006-08-07 21:52:48 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 3 Jonathan Kamens 2006-09-03 03:27:34 EDT
I can't figure out if this is still a problem.  I have /etc/cups/ppds.dat and
/etc/cups/lpoptions on my hard disk, but I don't know if they're simply left
over from a previous CUPS version and wouldn't be created if I reinstalled CUPS
from scratch now (a test I'm not willing to do because I don't want to blow away
my CUPS configuration).  I don't have /etc/cups/certs/0.  Any insights/
Comment 4 Tim Waugh 2006-09-07 08:29:23 EDT
/etc/cups/certs moved to /var/run/cups/certs.
/etc/cups/ppds.dat moved to /var/cache/cups.
Just leaves /etc/cups/lpoptions, which I've now handled like this:

%ghost %config(noreplace) /etc/cups/lpoptions

Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.