Bug 59032 - Fatal server error: could not open default font 'fixed'
Summary: Fatal server error: could not open default font 'fixed'
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-29 17:14 UTC by Brian Fristensky
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 05:00:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tar archive with log files for XFree86.0 and up2date (51.50 KB, application/octet-stream)
2002-01-29 17:18 UTC, Brian Fristensky
no flags Details

Description Brian Fristensky 2002-01-29 17:14:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
I did a fresh install of RH7.2 in November, and have routinely
run the Red Hat update agent each week to keep the system current.
On Sunday I ran the update agent, which included both kernel update
and XFree86 updates, among others. The next time I rebooted, 
X11 didn't work at all. I could run Xconfigurator and see the test
screen, but couldn't launch X.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.change permissions on fonts.dir to 600
2. restart xfs
3. run 'startx' or reboot
	

Additional info:

I saw a similar report on comp.os.linux.x, which pointed to  the
problem. It turns out that /usr/X11R6/lib/X11/fonts/misc/fonts.dir
was not world-readable. Its permissions were -rw-------, and
it was owned by root. I changed this file to be world-readable,
which didn't immediately fix the problem, until I realized I needed
to restart xfs (/sbin/xfs -restart). This completely restored X11.

I consider this to be an extremely serious bug because , although
trivial to fix, it completely kill X11, which means you don't
even have access to a browser, newsgroups, multiple windows,
admin tools -- al l the things that make it possible to discover
the problem. It essentially makes the whole system uselessl.

I think Red Hat should send an email announcement about this
bug to all up2date users, in addition to fixing the release of XFree86
that is downloaded by up2date.

(Note: I will attach log files for XFree86 and up2date with this report).

Comment 1 Brian Fristensky 2002-01-29 17:18:49 UTC
Created attachment 43937 [details]
Tar archive with log files for XFree86.0  and up2date

Comment 2 Mike A. Harris 2002-05-30 08:06:11 UTC
This problem can be caused by a great many things.  It is highly dependant
on how one has configured their system, and various other factors, and is
not due to a single pinpointable cause.  In order to conclude it is a bug
in the released packages, you'd have to troubleshoot it to determine the
exact cause of the problem and report that.  More likely than not, it is a
local issue, and not a bug in the packaging - otherwise you wouldn't be
the only person to have reported this.

Not reproduceable.


Note You need to log in before you can comment on or make changes to this bug.