Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590380 - [PATCH] s-c-kdump crashes on live media
[PATCH] s-c-kdump crashes on live media
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Roman Rakus
Han Pingtian
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 06:02 EDT by Lubomir Rintel
Modified: 2014-01-12 19:11 EST (History)
4 users (show)

See Also:
Fixed In Version: system-config-kdump-2.0.2.1-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:41:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix, apply with git am (2.61 KB, text/plain)
2010-05-09 06:02 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2010-05-09 06:02:41 EDT
Created attachment 412612 [details]
Proposed fix, apply with git am

Description of problem:

Traceback (most recent call last):
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 1826, in <module>
    win = MainWindow()
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 473, in __init__
    self.default_kernel = self.default_kernel_name()[:-1]
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 1422, in default_kernel_name
    default_kernel = self.dbus_object.getdefaultkernel()
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 206, in getdefaultkernel
    return self.dbus_object.getdefaultkernel (dbus_interface = "org.fedoraproject.systemconfig.kdump.mechanism")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.65 was not provided by any .service files

Version-Release number of selected component (if applicable):

system-config-kdump-2.0.2-6.el6.noarch

Additional info:

Since we do not support syslinux, and we probably would not be able to overwrite its configuration (e.g. on ROM media), just provide the user with a sane error message.

See the attached patch.
Comment 2 RHEL Product and Program Management 2010-05-09 07:11:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-05-09 08:29:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Roman Rakus 2010-05-19 14:18:28 EDT
Heh. Nice hit. Two things. 1) Why is s-c-kdump on live media? Ah, nevermind. 2) The check was missing, thanks for the patch!
Comment 5 Lubomir Rintel 2010-05-20 03:51:53 EDT
(In reply to comment #4)
> 1) Why is s-c-kdump on live media?

Duh, because I installed it there? :)

Default RHEL6 Beta 1 installation contained kdump, possibly due to a same reason, a comps group that dragged it in.

It's that useless anyway -- live images can be installed to hard driver via liveinst as they are, and hard drive installations are booted with grub, so s-c-kdump works happily there.
Comment 6 Roman Rakus 2010-05-25 12:40:44 EDT
I have applied your patch. This can be fixed in system-config-kdump-2.0.2.1-16.el6.
Comment 8 Alexander Todorov 2010-08-23 08:28:04 EDT
system-config-kdump-2.0.2.2-2.el6 in snap #12 LiveCD says:
"Don't know how to configure your bootloader".

Moving to VERIFIED.
Comment 9 releng-rhel@redhat.com 2010-11-10 16:41:43 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.