Bug 590384 - [PATCH] Can't install from the live media
[PATCH] Can't install from the live media
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ales Kozumplik
Release Test Team
:
: 591399 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 06:09 EDT by Lubomir Rintel
Modified: 2014-09-30 19:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.21.42-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:43:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (1.68 KB, text/plain)
2010-05-09 06:09 EDT, Lubomir Rintel
no flags Details
Traceback (166.23 KB, text/plain)
2010-05-09 06:10 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2010-05-09 06:09:16 EDT
Created attachment 412615 [details]
Proposed fix

Description of problem:

A LV could not be brought down since it was an active swap device.

Version-Release number of selected component (if applicable):

anaconda-13.21.20.5-1.el6.i686

Additional info:

With the attached patch the install succeeded. I'm not entirely sure about it; will attach a complete backtrace as well so that you can eventually come up with a better solution.
Comment 1 Lubomir Rintel 2010-05-09 06:10:07 EDT
Created attachment 412616 [details]
Traceback
Comment 3 RHEL Product and Program Management 2010-05-09 07:11:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 RHEL Product and Program Management 2010-05-09 08:30:03 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Ales Kozumplik 2010-05-11 04:05:02 EDT
Hi Lubomir,

I assume this is how you created the live images:
http://v3.sk/~lkundrak/blog/entries/rhel6-live.html

I'd like to know how did you start the installer: on livecd it's supposed to be run through the 'liveinst' script, which has an unconditional 'swapoff -a' call in it:
http://git.fedorahosted.org/git/?p=anaconda.git;a=blob;f=liveinst/liveinst;h=51eae2f2b7fee03b980bd38a665281be8b8a2a3a;hb=refs/heads/f13-branch

I tested F13 LiveCD with a swap on an LV and the install went smoothly.

Ales
Comment 6 Lubomir Rintel 2010-05-11 05:12:23 EDT
(In reply to comment #5)
> I assume this is how you created the live images:
> http://v3.sk/~lkundrak/blog/entries/rhel6-live.html

Yep.

> I'd like to know how did you start the installer: on livecd it's supposed to be
> run through the 'liveinst' script, which has an unconditional 'swapoff -a' call
> in it:
> http://git.fedorahosted.org/git/?p=anaconda.git;a=blob;f=liveinst/liveinst;h=51eae2f2b7fee03b980bd38a665281be8b8a2a3a;hb=refs/heads/f13-branch

That swapoff is way too early. The volume group in question was initialized by anaconda and a swap device with lv on it was also created. I'm not sure what called swapon against it, maybe it was anaconda as well?

> I tested F13 LiveCD with a swap on an LV and the install went smoothly.

That's strange, since I used Fedora scripts to build the live media. However, the issue is perfectly reproducible, so I suggest you try that yourself. Either build your own live media, or I can share mine somehow if you stop by at #fedora-cs.
Comment 7 David Cantrell 2010-05-11 09:39:46 EDT
QA,

We have fixes for livecds on RHEL-6, can we get a qa_ack please?
Comment 8 Ales Kozumplik 2010-05-11 10:20:33 EDT
So far I have identified those two F13 fixes we need to merge over the rhel6 in order to fix this.

f8f27c14140377d9a9a6c3c32294f27ee771af1f (the core fix for this bug)
57b6bc9de084c36681ad35faaf9a258163634875 (arbitrary complex dir structures)
c971e7fe9c00e33c66118f3ef53b5ce764b02924 (selected keyboard)
ad8cbf88d3dfe2a0189f09392b4ab97698f43b80 (syslog file)
0c496dc1069cb56ce444c4a11b0469348dedcc1a (udev environment)
Comment 13 Ales Kozumplik 2010-05-13 03:47:40 EDT
*** Bug 591399 has been marked as a duplicate of this bug. ***
Comment 15 Ales Kozumplik 2010-05-14 03:10:46 EDT
those f13-patches will have to be merged too:

5af00da374af665f8b0ae573776c012cc2ec4443 (clumens)
cf5440ad3f1faa83a5d97ea123e62c3a3f85ad26 (clumens)
Comment 16 Ales Kozumplik 2010-05-17 05:16:23 EDT
Should be working in anaconda-13.21.42-1.

Those patches were cherry-picked from f13 to fix this:
82428862fe03f579b18aafabe0d1b3c1dd4aaca7
9697f773895dfb938d91f3aba1efae5240610dec
b5fd071ef4cd4139a57d7ac5c92709bf7e3f4573
7222f8b3549982ca75d9d9edc741b44911605b53
acd029cb07ddefb1b394d5f9abc0380e0980adec
Comment 18 Grant Williamson 2010-05-31 08:04:04 EDT
If I try a liveinst with anaconda-13.21.45-1.el6 I get.

umount: /media/*: not found
  No volume groups found
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 697, in <module>
    check_memory(opts, 't')
  File "/usr/sbin/anaconda", line 376, in check_memory
    if opts.stage2.startswith(('http', 'ftp', '@')):
AttributeError: 'NoneType' object has no attribute 'startswith'
Comment 19 Ales Kozumplik 2010-06-01 03:20:18 EDT
Grant,

that's a known issue fixed in a later anaconda. See bug 595284.

Ales
Comment 20 Alexander Todorov 2010-07-14 11:58:01 EDT
I've done a default install with 0707.4 LiveCD image today. I've logged in into GNOME and started the anaconda installer via the desktop icon. I didn't get any traceback or error. Installation completed and I was able to boot into the newly installed system. Moving to VERIFIED.
Comment 21 releng-rhel@redhat.com 2010-11-10 14:43:11 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.