Bug 590525 - NetworkManager did not pick up the active link
NetworkManager did not pick up the active link
Status: CLOSED DUPLICATE of bug 520146
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 00:20 EDT by CAI Qian
Modified: 2010-05-13 10:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 10:25:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2010-05-10 00:20:55 EDT
Description of problem:
After installed from the RHEL6 Beta 1 DVD x86_64 ISO and upgraded the system to the snapshot 1, the NetworkManager did not pick up the active link which left no network in place by default. The workaround is to manually click the active link from the GUI.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.0-6.git20100408.el6.x86_64

How reproducible:
always
Comment 1 CAI Qian 2010-05-10 01:54:26 EDT
# cat /etc/sysconfig/network-scripts/ifcfg-eth1
# Intel Corporation 82566DM-2 Gigabit Network Connection
DEVICE=eth1
HWADDR=00:1E:4F:A8:AE:EF
ONBOOT=no

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
HWADDR=00:E0:4C:0B:16:0E
ONBOOT=no
Comment 2 Dan Williams 2010-05-12 14:40:49 EDT
Yeah, the issue is ONBOOT=no which is written by the installer.

This is because the install you did was not done using the network, and for security reasons networking is not started by default on reboot.  Had the install been done with the boot.iso or netinst, since network was used to install then networking would be enabled on reboot.  This is since fixed by allowing post-install configuration of network interfaces, though I don't know which bug that one is.

The Fedora counterpart is bug #498207.
Comment 3 David Cantrell 2010-05-13 10:25:41 EDT
The core problem here is being addressed by the patches for bug #520146.  Anaconda will offer users the ability to configure network devices on the target system during installation, so even in instances where you are performing a non-network installation, you can still configure network settings.

As for upgrading from beta 1 to snapshot 1, that's a non-issue.  First, we don't care about upgrades between testing releases.  Second, the behavior you are seeing is expected.  On upgrade, anaconda will honor the settings it finds in the ifcfg files on the system you are upgrading.

*** This bug has been marked as a duplicate of bug 520146 ***

Note You need to log in before you can comment on or make changes to this bug.