Bug 590589 - PackageKit couldn't find suitable plugin to view ogv file (totem)
PackageKit couldn't find suitable plugin to view ogv file (totem)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: PackageKit (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On:
Blocks: 599016
  Show dependency treegraph
 
Reported: 2010-05-10 05:03 EDT by Lubos Kocman
Modified: 2010-08-30 15:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-30 10:56:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
problematic video (4.44 MB, video/ogg)
2010-05-10 05:03 EDT, Lubos Kocman
no flags Details
used repositories (3.21 KB, text/plain)
2010-05-10 05:04 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-05-10 05:03:51 EDT
Created attachment 412762 [details]
problematic video

Description of problem:

PackageKit failed to find a suitable codec plugin for .ogv

Version-Release number of selected component (if applicable):

RHEL 6 Workstation snapshot 2 i686

(Still can't play video with following list of packages)

PackageKit-cron-0.5.8-2.el6.i686
PackageKit-gstreamer-plugin-0.5.8-2.el6.i686
PackageKit-glib-0.5.8-2.el6.i686
PackageKit-command-not-found-0.5.8-2.el6.i686
PackageKit-gtk-module-0.5.8-2.el6.i686
PackageKit-0.5.8-2.el6.i686
PackageKit-device-rebind-0.5.8-2.el6.i686
PackageKit-backend-devel-0.5.8-2.el6.i686
PackageKit-browser-plugin-0.5.8-2.el6.i686
PackageKit-yum-0.5.8-2.el6.i686
PackageKit-glib-devel-0.5.8-2.el6.i686
PackageKit-docs-0.5.8-2.el6.noarch
PackageKit-debug-install-0.5.8-2.el6.i686
PackageKit-yum-plugin-0.5.8-2.el6.i686
PackageKit-qt-0.5.8-2.el6.i686
PackageKit-debuginfo-0.5.8-2.el6.i686
PackageKit-qt-devel-0.5.8-2.el6.i686
libtheora-1.1.0-1.el6.i686
gstreamer-plugins-good-0.10.18-1.el6.i686
gstreamer-plugins-bad-free-debuginfo-0.10.17-4.el6.i686
gstreamer-plugins-bad-free-devel-0.10.17-4.el6.i686
phonon-backend-gstreamer-4.6.2-13.el6.i686
gstreamer-plugins-good-debuginfo-0.10.18-1.el6.i686
gstreamer-devel-0.10.26-2.el6.i686
gstreamer-plugins-bad-free-devel-docs-0.10.17-4.el6.i686
gstreamer-plugins-base-0.10.26-1.el6.i686
gstreamer-plugins-base-debuginfo-0.10.26-1.el6.i686
gstreamer-plugins-bad-free-extras-0.10.17-4.el6.i686
gstreamer-plugins-bad-free-0.10.17-4.el6.i686
gstreamer-plugins-good-devel-0.10.18-1.el6.i686
gstreamer-plugins-base-devel-0.10.26-1.el6.i686
gstreamer-0.10.26-2.el6.i686
totem-2.28.5-5.el6.i686


(I'm able to view video on my personal laptop with complete codec pack from fluendo)

How reproducible:


Steps to Reproduce:
1. Obtain clean installed RHEL 6.0 snapshot 2
2. Be sure that PackageKit-* and totem are installed
3. remove libtheora using rpm -e --nodeps libtheora (to not remove totem and so on...)
4. try to open any .ogv video (one is attached)
  
Actual results:

Dialog asking to search for suitable plugin appeared:

"""
nautilus requires an additional plugin to decode this file

The following plugins is required
Theora decored

Do you want to search for this now?

Help | Close | Search
"""

 The result of search is:

"Failed to search for plugin. Could not find in any configured software source"


Expected results:

libtheora or any suitable plugin will be installed


Additional info:

following ogv video can't be "viewed with video output" even with libtheora and gstreamer-plugins-* installed

list of used repositories is attached repos.txt
Comment 1 Lubos Kocman 2010-05-10 05:04:44 EDT
Created attachment 412763 [details]
used repositories
Comment 2 Tomas Pelka 2010-05-10 05:09:02 EDT
Reproducer in description, giving qa_ack.
Comment 4 RHEL Product and Program Management 2010-05-10 06:48:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Richard Hughes 2010-05-10 10:42:04 EDT
I'm sure "rpm -e --nodeps libtheora" is _not_ the right way to test this; that assumes libtheora is the thing providing the codec (according to rpm), which it's not, it'll be a provide in the gstreamer-foo packages.
Comment 6 RHEL Product and Program Management 2010-07-15 10:23:37 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 8 Lubos Kocman 2010-08-30 10:56:17 EDT
Agreeing on that this is not a bug according to all dependencies that libtheora takes.

Note You need to log in before you can comment on or make changes to this bug.