Bug 590591 - NoOption Error for latest RHEL6 nightly during install
NoOption Error for latest RHEL6 nightly during install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 05:20 EDT by Huzaifa S. Sidhpurwala
Modified: 2010-07-02 16:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.40-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:48:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2010-05-10 05:20:08 EDT
Cannot install latest RHEL6 nightly from 8th May 2010, i get the following traceback.

anaconda 13.21.37 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/ConfigParser.py", line 540, in get
    raise NoOptionError(option, section)
  File "/usr/lib/anaconda/yuminstall.py", line 611, in _getAddons
    validAddons = c.get(section, "addons").split(",")
  File "/usr/lib/anaconda/yuminstall.py", line 783, in doConfigSetup
    addons = self._getAddons(repo.mirrorlist or repo.baseurl[0])
  File "/usr/lib/anaconda/yuminstall.py", line 353, in setup
    self.doConfigSetup(root=self.anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 1187, in doBackendSetup
    self.ayum.setup()
  File "/usr/lib/anaconda/backend.py", line 285, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 657, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1107, in <module>
    anaconda.intf.run(anaconda)
NoOptionError: No option 'addons' in section: 'variant-Workstation'


All logs at: 
http://helpdesk-rnd.corp.redhat.com/~huzaifas/rhel6-nooptions/
Comment 2 RHEL Product and Program Management 2010-05-10 06:48:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lumens 2010-05-10 15:40:36 EDT
Got a patch ready to go, just need a QA ack.
Comment 4 Huzaifa S. Sidhpurwala 2010-05-10 21:59:36 EDT
Can i have an updates.img for testing?
Comment 5 Chris Lumens 2010-05-12 14:34:03 EDT
Make sure you're using the latest tree, and...

updates=http://clumens.fedorapeople.org/590591.img
Comment 6 Huzaifa S. Sidhpurwala 2010-05-13 02:26:42 EDT
Works for me.
Comment 9 Alexander Todorov 2010-06-15 06:33:51 EDT
anaconda 13.21.50 (0610.n.0 tree). No such traceback with the Workstation variant. Install completed successfully. Moving to VERIFIED.
Comment 10 releng-rhel@redhat.com 2010-07-02 16:48:48 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.