Bug 590707 - firefox segfaults after Pango failed to choose a font
firefox segfaults after Pango failed to choose a font
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
: Reopened, Triaged
: 591481 (view as bug list)
Depends On:
Blocks: 591481
  Show dependency treegraph
 
Reported: 2010-05-10 10:25 EDT by Aleš Mareček
Modified: 2013-10-31 10:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 591481 (view as bug list)
Environment:
Last Closed: 2010-06-25 06:13:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log made by strace (42.38 KB, text/plain)
2010-05-10 10:25 EDT, Aleš Mareček
no flags Details
backtrace (13.07 KB, text/plain)
2010-06-23 09:08 EDT, Jan Kaluža
no flags Details

  None (edit)
Description Aleš Mareček 2010-05-10 10:25:25 EDT
Created attachment 412854 [details]
log made by strace

Description of problem:
I am running machine in rhts and forwarding X session via ssh. After "firefox" command is used, segfault is risen. It appeared on ppc64 machine. I wasn't able to reproduce it on i386 and x86_64 (other arch were untesed).

Version-Release number of selected component (if applicable):
firefox-3.6.3-4.el6.ppc64, RHEL6.0-Snapshot-2

How reproducible:
Probably always

Steps to Reproduce:
1. intsall RHEL6.0-Snapshot-2 with firefox
2. ssh -X -v root@your.machine
3. firefox
  
Actual results:
/usr/lib64/firefox-3.6/run-mozilla.sh: line 131:  4632 Segmentation fault      "$prog" ${1+"$@"}

Expected results:
no segfaults

Additional info:
More info in log file attached.
Comment 2 RHEL Product and Program Management 2010-05-10 11:40:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Aleš Mareček 2010-05-12 07:10:30 EDT
Now I am able to reproduce it on all architectures. See following instructions:
1. Install tigervnc-server: yum install tigervnc-server
2. Start vnc server: vncserver
 * and set password for your sessions
3. See on which port is vnc running:  ps aux | grep Xvnc
4. Set variable DISPLAY, for example: export DISPLAY=:1.0
 * mines was on 1 (I suppose it's by default)
5. Run firefox: firefox
6. You should be able to see something like:

(firefox:6431): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: /bin/dbus-launch terminated abnormally without any error message)

(firefox:6431): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: /bin/dbus-launch terminated abnormally without any error message)
/usr/lib64/firefox-3.6/run-mozilla.sh: line 131:  6431 Segmentation fault      "$prog" ${1+"$@"}
Comment 4 Aleš Mareček 2010-05-12 07:36:47 EDT
Thunderbird is also affected (Bug #591481).
Comment 6 Christopher Aillon 2010-06-04 18:52:06 EDT
Ales, can you provide a gdb backtrace?
Comment 8 RHEL Product and Program Management 2010-06-11 12:34:41 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 11 Jan Kaluža 2010-06-23 09:08:09 EDT
Created attachment 426260 [details]
backtrace

I've reproduced the problem and I'm attaching backtrace.
Comment 16 Martin Stransky 2010-06-25 04:25:29 EDT
*** Bug 591481 has been marked as a duplicate of this bug. ***
Comment 17 Martin Stransky 2010-06-25 06:13:08 EDT
Moved upstream - https://bugzilla.mozilla.org/show_bug.cgi?id=574613

Note You need to log in before you can comment on or make changes to this bug.