Bug 590715 - setroubleshoot icon in desktop file
Summary: setroubleshoot icon in desktop file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 14:35 UTC by Michael Monreal
Modified: 2010-10-04 19:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-04 19:13:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Monreal 2010-05-10 14:35:04 UTC
setroubleshoot.desktop includes the line

---
Icon=/usr/share/setroubleshoot/gui/setroubleshoot_icon.svg
---

/usr/share/setroubleshoot/gui/setroubleshoot_icon.svg does not exist
/usr/share/setroubleshoot/gui/setroubleshoot_icon.png exists but is a link to /usr/share/icons/hicolor/24x24/apps/setroubleshoot_icon.png

Looks like the panel actually drops the path and extension, so it displays the correct icon. However, nautilus for example does not seem to do the same, it does not display any icon.

Just drop the path and extension from the .desktop file and remove the link in /usr/share/setroubleshoot/gui (linking png to svg is not a great idea anyway...)

[Offtopic: what is that icon supposed to mean?!]

Comment 1 Daniel Walsh 2010-05-10 16:22:50 UTC
Check engine light.

http://danwalsh.livejournal.com/35888.html

Icon=setroubleshoot_icon.png


Seems to work.

Fixed in setroubleshoot-2.2.82-1.el6

Comment 2 Michael Monreal 2010-05-10 17:12:08 UTC
Heh... "I was not familiar with this symbol"...

I don't think most users will be able to make the connection. Even of those users who actually drive a car, many will not have seen this, ever. And even people who know the metaphor will have a very hard time undestanding the 16x16 version...


Note You need to log in before you can comment on or make changes to this bug.