Bug 590755 - 'system-config-kickstart --generate ' is not capturing the current partition information of the system
'system-config-kickstart --generate ' is not capturing the current partition ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kickstart (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 11:50 EDT by Jeff Bastian
Modified: 2010-10-23 11:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 12:56:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2010-05-10 11:50:17 EDT
Description of problem:
'system-config-kickstart --generate' creates a kickstart file based on the current system.  It correctly captures packages, root password, locale data and more, however, the disk partitioning section is very generic:
   # Clear the Master Boot Record
   zerombr
   # Partition clearing information
   clearpart --linux

Version-Release number of selected component (if applicable):
system-config-kickstart-2.6.19.8-2.el5.noarch

How reproducible:
every time

Steps to Reproduce:
1. system-config-kickstart --generate /tmp/ks.cfg
  
Actual results:
no partition commands in /tmp/ks.cfg

Expected results:
partition commands based on system profile

Additional info:
From examining /usr/share/system-config-kickstart/profileSystem.py I can see that it queries the system for locale, timezone, root password, etc:
        self.getLang()
        self.getKeyboard()
        self.getTimezone()
        self.getRootPassword()
        self.getSELinux()
        self.getPackages()

But for the disk partitioning, it's just sets some defaults:
        self.kickstartData.zerombr = True
        self.kickstartData.clearpart["type"] = CLEARPART_TYPE_LINUX
Comment 1 Chris Lumens 2010-05-10 12:06:14 EDT
Yeah, this is known.  system-config-kickstart's partitioning support is pretty lacking.  For instance, it doesn't even support LVM.  Since we don't even have support for better profiling in rawhide or RHEL6, there's no code I can use to backport so it's highly unlikely I'm going to be able to fix this.
Comment 2 RHEL Product and Program Management 2010-05-10 12:56:29 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.