Bug 590837 - kernel-2.6.33.3-85.fc13 doesn't support xstate ptrace
Summary: kernel-2.6.33.3-85.fc13 doesn't support xstate ptrace
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 19:16 UTC by H.J. Lu
Modified: 2010-05-21 18:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-21 18:26:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to enable xstate ptrace (16.62 KB, text/plain)
2010-05-10 19:16 UTC, H.J. Lu
no flags Details

Description H.J. Lu 2010-05-10 19:16:48 UTC
Created attachment 412942 [details]
A patch to enable xstate ptrace

kernel-2.6.33.3-85.fc13 doesn't support xstate ptrace.
I can't debug AVX programs on my Sandy Bridge machine
with gdb-7.1-18.fc13.x86_64 which supports xstate pptrace.
I have been using this patch backported from 2.6.34
and it works for me.

Comment 1 Roland McGrath 2010-05-21 18:26:17 UTC
It's a 2.6.34 feature, and we'll have a 2.6.34 kernel soon enough.


Note You need to log in before you can comment on or make changes to this bug.