Bug 590877 - evo doesn't make all pasted links clickable
evo doesn't make all pasted links clickable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtkhtml3 (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 16:49 EDT by Issue Tracker
Modified: 2010-11-10 15:37 EST (History)
5 users (show)

See Also:
Fixed In Version: gtkhtml3-3.28.3-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:37:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for gtkhtml3 (1.20 KB, patch)
2010-05-11 09:52 EDT, Milan Crha
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 618368 None None None Never

  None (edit)
Description Issue Tracker 2010-05-10 16:49:20 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-05-10 16:49:21 EDT
Event posted on 05-10-2010 04:36pm EDT by woodard

Description of problem:
When you are composing a message in evolution and you type or paste a URL, then it turns it into a link (blue and underlined). However, if you paste a couple of URLs it only seems to make the last one that you paste clickable.

How reproducible:
always

Steps to Reproduce:

Actual results:
only the last link pasted is clickable

Expected results:
all the links pasted are clickable.

Additional info:
evolution-2.28.3-3.el6.x86_64

This event sent from IssueTracker by kbaxley  [LLNL (desktop)]
 issue 870763
Comment 2 Issue Tracker 2010-05-10 16:49:22 EDT
Event posted on 05-10-2010 04:44pm EDT by kbaxley

Steps to reproduce:

Paste multiple URLs into a compose window for an email.
Note how the last URL is the only one that is clickable.
All URLs should be clickable.


This event sent from IssueTracker by kbaxley  [LLNL (desktop)]
 issue 870763
Comment 3 RHEL Product and Program Management 2010-05-10 17:42:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Milan Crha 2010-05-11 09:39:01 EDT
Thanks for a bug report. I see the same even on actual master, only the first URL in each pasted paragraph is properly recognized as a URL, but not any following in the given paragraph.
Comment 5 Milan Crha 2010-05-11 09:52:19 EDT
Created attachment 413149 [details]
patch for gtkhtml3

for gtkhtml3;

This is fixing the issue for me.
Comment 6 Milan Crha 2010-05-11 10:11:47 EDT
Upstream bug report I filled for this (I didn't find any already filled):
https://bugzilla.gnome.org/show_bug.cgi?id=618368
Comment 7 Matthew Barnes 2010-05-24 09:26:04 EDT
Devel ACK: Patch available.
Comment 8 Tomas Pelka 2010-05-28 03:19:15 EDT
Reproducer:
 - check if all URLs are displayed properly.

Giving qa_ack.
Comment 9 Matthew Barnes 2010-06-17 13:19:53 EDT
Patch applied to gtkhtml3-3.28.3-3.el6.
Comment 10 Tomas Pelka 2010-06-21 09:16:05 EDT
Verified on gtkhtml3-3.28.3-3.el6.
Comment 11 Issue Tracker 2010-07-26 09:17:41 EDT
Event posted on 07-23-2010 05:39pm EDT by woodard

gtkhtml3-3.28.3-3.el6.x86_64 still has some problmes for example pasting
this text: 

-------------
It was done now that we know more about why the workload is causing
problems. Here is the patch whose logic seems to be causing the problem:

http://sourceware.org/git/?p=glibc.git;a=blobdiff;f=malloc/malloc.c;h=890d3669e2bc9ea0bdf56484f4199d205025696a;hp=da230d34935b01dc0f8bceb0dc9d2a4b60df8d95;hb=1d05c2fb9c6fb297a39317231f31a75115e64f75;hpb=be7ffd91f806e5615b9c6a42a63e96c3dc3c54ad
It appears to have been written by Arjen van de Ven and Valarie Hensen
http://sourceware.org/git/?p=glibc.git;a=commit;f=malloc/malloc.c;h=1d05c2fb9c6fb297a39317231f31a75115e64f75

The discussion that led to it is:
http://sourceware.org/ml/libc-alpha/2006-03/msg00033.html
http://sourceware.org/ml/libc-alpha/2006-03/msg00043.html
-----------

Didn't work, for 3 out of 4 links. The first three. I think that the
difference is the links are on a line by themselves. I think that the
logic seems to be keyed off of trailing space and it doesn't pick up the
\n.


This event sent from IssueTracker by kbaxley 
 issue 870763
Comment 12 releng-rhel@redhat.com 2010-11-10 15:37:34 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.