Bug 59092 - gcc 3.1-0.18 miscompiles MICO 2.3.6 (www.mico.org)
gcc 3.1-0.18 miscompiles MICO 2.3.6 (www.mico.org)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc3 (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-30 15:04 EST by Peter Klotz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-01 01:12:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Klotz 2002-01-30 15:04:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
gcc 3.1-0.10 was able to compile MICO 2.3.6 but gcc 3.1-0.18 cannot. The 
(virtual inheritance) bug that crashed the idl compiler in the gcc 3.0.x 
series has GNATS #3145. It should have been fixed in 3.1.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Get mico-2.3.6.tar.gz
2.Remove all occurrences of -Werror in the configure script
3.Remove ios::noreplace from idl/codegen-c++.cc in lines 220/221
4.Perform configure
5.Perform make	

Actual Results:  The just made idl compiler crashes

make[2]: Entering directory `/root/development/mico/mico/coss/naming'
/root/development/mico/mico/./idl/idl --c++-skel --name CosNaming \
	../../include/mico/CosNaming.idl
make[2]: *** [CosNaming.cc] Segmentation fault
make[2]: Leaving directory `/root/development/mico/mico/coss/naming'
make[1]: *** [sublib] Error 1
make[1]: Leaving directory `/root/development/mico/mico/coss'


Expected Results:  It should compile. It works under gcc 2.96 and gcc 3.1-
0.10. It never worked under gcc 3.0.x (see above, GNATS bug #3145).

Additional info:
Comment 1 Peter Klotz 2002-02-01 01:12:05 EST
This problem is solved in gcc 3.1-0.19.

Note You need to log in before you can comment on or make changes to this bug.