Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590945 - Ethernet NDIS Test 6.0 failed for WHQL testing (1c_kernelcalls test failed on DbgPrint function) on Windows 2008 x86
Ethernet NDIS Test 6.0 failed for WHQL testing (1c_kernelcalls test failed on...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.0
All Windows
low Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 23:34 EDT by Xiaoli Tian
Modified: 2010-11-11 10:02 EST (History)
5 users (show)

See Also:
Fixed In Version: virtio-win-1.1.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:02:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failure log (2.11 KB, text/plain)
2010-05-10 23:34 EDT, Xiaoli Tian
no flags Details

  None (edit)
Description Xiaoli Tian 2010-05-10 23:34:08 EDT
Created attachment 413034 [details]
failure log

Description of problem:

NDIS Test 6.0 failed for 4 failures when running "start test client "task,
the task log will be attached.

Version-Release number of selected component (if applicable):
virtio-win driver version:05/03/2010,6.0.209.605
kernel:2.6.32-19.el6,x86_64


How reproducible:
always

Steps to Reproduce:
1.Prepare the WHQL network test environment
2.Start two windows 2008 x86 guest with the following command:
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -name nic1-08-32 -m 4G -smp 4 -net nic,vlan=1,macaddr=00:42:59:7b:26:e1,model=rtl8139 -net tap,vlan=1,script=/etc/qemu-ifup -net nic,vlan=2,macaddr=00:1b:e1:65:c1:43,model=virtio -net tap,vlan=2,ifname=virtio1,script=/etc/qemu-ifup-private -net nic,vlan=3,macaddr=00:5b:3a:66:23:22,model=virtio -net tap,vlan=3,ifname=virtio2,script=/etc/qemu-ifup-private -drive file=/home/WHQL/NIC1-08-32.qcow2,if=ide -uuid 0483f574-c3a1-4231-af31-2a16277911d0 -vnc :1&
3.Start to test Ethernet NDIS test 6.0

  
Actual results:
failed

Expected results:
passed

Additional info:
the failure log will be attached
Comment 2 RHEL Product and Program Management 2010-05-11 00:38:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Yaniv Kaul 2010-05-11 02:22:15 EDT
"No remote support adapter available!" - looks like a test configuration error.
Comment 4 Xiaoli Tian 2010-05-11 04:07:34 EDT
(In reply to comment #3)
> "No remote support adapter available!" - looks like a test configuration error.   
it's not a configuration error,
the remote support adapter is always lost during testing.
Comment 5 Yaniv Kaul 2010-05-11 04:09:13 EDT
So it's a regression. It used to work. Please mark it as such.
Comment 6 Yan Vugenfirer 2010-05-11 04:50:58 EDT
(In reply to comment #3)
> "No remote support adapter available!" - looks like a test configuration error.    

I must agree with Yaniv.

whqlconfigcheck is the first test that runs and if it fails no reason to run anything else. It should check that the setup is ready for testing.

We need to understand why it is failing.

You could run this test manually (start ndis tester manually server\client).
Comment 7 Yan Vugenfirer 2010-05-11 04:53:08 EDT
Also model of support NIC is rtl8139. We usually use e1000 as support adapter and I suggest to stick with it (you might need to install Intel provided drivers starting from win2003).
Comment 8 Xiaoli Tian 2010-05-12 04:18:40 EDT
(In reply to comment #7)
> Also model of support NIC is rtl8139. We usually use e1000 as support adapter
> and I suggest to stick with it (you might need to install Intel provided
> drivers starting from win2003).    

Hi
"whqlconfigcheck" failure is caused by the DTM Controller,I have tested it again,there are still two failures.
failure log is :


Report Summary 

Test Results 

Description Total Pass Fail Warning Blocked Skipped Pass Rate 

 2784 2775 2 7 0 0 99.93% 

 TimeStamp Total Pass Fail Warning Blocked Skipped Pass Rate 

5/12/2010 1:22:49.023 PM 2784 2775 2 7 0 0 99.93% 

 

Machine, Process, and OS Information 

Machine Name OS Version Build VBL BuildDate Platform Language ServicePack Config 

 (No Machine Information Trace Available) 

 Base Time Process ID Thread ID Process Name 

5/12/2010 10:59:46.023 AM 3540 3544 C:\WTT\JobsWorkingDir\Tasks\WTTJobRunA9AF01F2-EC2D-4704-9D4D-A84BC09CBB0A\ndistest\bin\NDINFO.exe 

 

Report Details 

Test Cases 

Title Result 

 Failed 

 Start Test 5/12/2010 11:01:49.023 AM 1c_kernelcalls 

Message 5/12/2010 11:01:49.023 AM 

This script finds out what are the Kernel calls that the driver is making and then

checks to see if they are legal calls to make. In some of the cases of illegal calls,

the log file will also contains information on which legal functions can be substituted

for illegal function call!



 

End Test 5/12/2010 11:01:51.023 AM 1c_kernelcalls 

Result:   Fail 

 

 Failed 

 Start Test 5/12/2010 11:01:51.023 AM Verifying calls made to NTOSKRNL.EXE 

Error 5/12/2010 11:01:51.023 AM Failed on function call to DbgPrint in module NTOSKRNL.EXE! This is a debug version of the driver. 

File:    Line: 0 

Error Type:   NT_STATUS 

Error Code:   0x51d0 

Error Text:   Error 0x000051d0 

End Test 5/12/2010 11:01:51.023 AM Verifying calls made to NTOSKRNL.EXE 

Result:   Fail 

Repro:   1c_kernelcalls 

 

qemu command is :/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2 -name nic1-08-32 -m 4G -smp 4 -net nic,vlan=1,macaddr=00:42:69:7b:26:e1,model=e1000 -net tap,vlan=1,script=/etc/qemu-ifup -net nic,vlan=2,macaddr=00:1b:e1:66:c1:53,model=virtio -net tap,vlan=2,script=/etc/qemu-ifup-private -net nic,vlan=3,macaddr=00:5b:3a:66:53:33,model=virtio -net tap,vlan=3,script=/etc/qemu-ifup-private -drive file=/home/WHQL/win2008x86/win08-32-nic.qcow2,if=ide -fda /home/WHQL/virtio_RHEL6/virtio-win-1.1.0-0.vfd -cdrom /home/WHQL/32/Windows2008-x86-customized.iso -boot d -uuid f1f79f4f-8bdd-4ebf-bf4e-dfc4a00b885b -vnc :1&'

cpu information is:processor       : 15
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Xeon(R) CPU           E5520  @ 2.27GHz
stepping        : 5
cpu MHz         : 2261.120
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 3
cpu cores       : 4
apicid          : 7
initial apicid  : 7
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology tsc_reliable nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 4521.29
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management:
Comment 9 Yan Vugenfirer 2010-05-12 04:29:58 EDT
What DTM version are you using?

Until what date we can use DTM 1.5?
Comment 10 Xiaoli Tian 2010-05-12 05:54:53 EDT
(In reply to comment #9)
> What DTM version are you using?
> 
> Until what date we can use DTM 1.5?    


DTM version is 1.5.7565.000
I also don't know  until what date we can use DTM 1.5,it depends on MS.
Comment 11 Xiaoli Tian 2010-05-14 04:44:01 EDT
This bug also exists in WHQL Network testing for Windows 7 and Windows 2008-x64
The failure log is as following:
Test Results 

Description Total Pass Fail Warning Blocked Skipped Pass Rate 

 2847 2838 2 7 0 0 99.93% 

 TimeStamp Total Pass Fail Warning Blocked Skipped Pass Rate 

5/13/2010 9:16:35.812 AM 2847 2838 2 7 0 0 99.93% 

 

Machine, Process, and OS Information 

Machine Name OS Version Build VBL BuildDate Platform Language ServicePack Config 

 (No Machine Information Trace Available) 

 Base Time Process ID Thread ID Process Name 

5/13/2010 7:08:11.812 AM 1960 1812 C:\WTT\JobsWorkingDir\Tasks\WTTJobRun4D75B37B-C86B-4C4F-A60D-BB10E2ABBA29\ndistest\bin\NDINFO.exe 

 

Report Details 

Test Cases 

Title Result 

 Failed 

 Start Test 5/13/2010 7:09:14.812 AM 1c_kernelcalls 

Message 5/13/2010 7:09:14.812 AM 

This script finds out what are the Kernel calls that the driver is making and then

checks to see if they are legal calls to make. In some of the cases of illegal calls,

the log file will also contains information on which legal functions can be substituted

for illegal function call!



 

End Test 5/13/2010 7:09:15.812 AM 1c_kernelcalls 

Result:   Fail 

 

 Failed 

 Start Test 5/13/2010 7:09:15.812 AM Verifying calls made to NTOSKRNL.EXE 

Error 5/13/2010 7:09:15.812 AM Failed on function call to DbgPrint in module NTOSKRNL.EXE! This is a debug version of the driver. 

File:    Line: 0 

Error Type:   NT_STATUS 

Error Code:   0x51d0 

Error Text:   Error 0x000051d0 

End Test 5/13/2010 7:09:15.812 AM Verifying calls made to NTOSKRNL.EXE 

Result:   Fail 

Repro:   1c_kernelcalls
Comment 15 Qunfang Zhang 2010-07-16 02:39:37 EDT
This issue still exists on virtio-win-1.1.7-2. After get the result of latest driver, will update bz.
Comment 16 Yan Vugenfirer 2010-07-20 04:46:07 EDT
Additional calls found in VirtIO library - they are failing the test.
Comment 18 Yan Vugenfirer 2010-07-27 04:09:35 EDT
The fix for this bug is needed to pass WHQL
Comment 20 Qunfang Zhang 2010-08-06 02:10:20 EDT
Update:
The issue is verified pass on win2k8-64, win2k8-R2 and win7-64 using virtio-win-1.1.9-0.
And it also passed on winxp-32 using virtio-win-1.1.10-0.
After get the other guests' result, I will change the status to VERIFIED.
Comment 21 Qunfang Zhang 2010-08-09 06:04:07 EDT
This issue is verified pass on win2k8-64, win2k8-R2 and win7-64 using
virtio-win-1.1.9-0.
And passed on winxp-32, win7-32, win2k8-32, win2k3-32.

So, I will change the status to VERIFIED.
Comment 22 Qunfang Zhang 2010-08-09 06:04:38 EDT
(In reply to comment #21)
> This issue is verified pass on win2k8-64, win2k8-R2 and win7-64 using
> virtio-win-1.1.9-0.
> And passed on winxp-32, win7-32, win2k8-32, win2k3-32.
 winxp-32, win7-32, win2k8-32, win2k3-32 passed on virtio-win-1.1.10-0.
> 
> So, I will change the status to VERIFIED.
Comment 23 releng-rhel@redhat.com 2010-11-11 10:02:01 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.