Bug 59099 - wine can't load libuser.so
wine can't load libuser.so
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: wine (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-30 18:04 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-30 18:04:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-30 18:04:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
When you try and run wine programs you get:

[long@shibby cdrom]$ wine setup.exe
err:module:BUILTIN_LoadModule loaded .so but dll user.dll still not found
Could not load 'USER.DLL' required by 'BOOTSTRP', error=2
[long@shibby cdrom]$ 

This is because wine needs to load /usr/lib/wine/libuser.so but due to the way
/etc/ld.so.conf is shipped from redhat it instead tries to load
/usr/lib/libuser.so which is the wrong one.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Find a windows executable that requires USER.DLL, such as setup.exe on the
Office 97 CD.
2.Run 'wine setup.exe'
3.
	

Actual Results:  [long@shibby cdrom]$ wine setup.exe
err:module:BUILTIN_LoadModule loaded .so but dll user.dll still not found
Could not load 'USER.DLL' required by 'BOOTSTRP', error=2


Expected Results:  It should have started the Office97 installer, which is what
happens if I 'export LD_LIBRARY_PATH=/usr/lib/wine' before trying to run wine.

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-01-31 08:13:24 EST
I've replaced /usr/bin/wine with a shell script doing just that in 20020130. 

Note You need to log in before you can comment on or make changes to this bug.