Bug 591002 - Encrypted MicroSSD card asks to be unlocked everytime after suspend
Encrypted MicroSSD card asks to be unlocked everytime after suspend
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 03:33 EDT by Nikolai Maziashvili
Modified: 2012-07-11 13:52 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 13:52:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nautilus_places (37.18 KB, image/png)
2010-05-11 03:33 EDT, Nikolai Maziashvili
no flags Details

  None (edit)
Description Nikolai Maziashvili 2010-05-11 03:33:03 EDT
Created attachment 413057 [details]
nautilus_places

Description of problem:

In my laptop i have microSSD slot were i keep encrypted ssd card for document backup purposes.
When i first booted into freshly installed F13 (GNOME) and tried to open/mount ssd card i was asked to unlock it and got options to let system remember password for certain time (i chose "remember forever" option).
And indeed after every reboot of the system card would mount automatically.
But when i suspended system and came back from suspend i got question about unlocking the card again.
When i type correct password i get following error:
"Error unlocking device: cryptsetup exited with exit code 239: Device udisks-luks-uuid-e6cd3bc5-42f2-46fb-b18b-468ff578525e-uid500 already exists."

Which is true because i can access my ssd card.
And when i type wrong password notification just disappears.

There is also one annoyance - whether i type correct password or not in Nautilus under places new entry of my ssd storage shows up. Like if i suspend 4 times then there is a 4 SSD storage places in nautilus I added image to show you what i mean)

Version-Release number of selected component (if applicable):
F13, 2.6.33.3-85.fc13.i686.PAE

How reproducible:
every time

Steps to Reproduce:
1. keep encrypted ssd card in the laptop
2. suspend laptop (and wake it)
3. also check nautilus "places"
  
Actual results:
after suspend i get asked for unlocking encrypted disk while it is already unlocked.

Expected results:
not to get asked for unlocking disk

Additional info:
Comment 1 Nikolai Maziashvili 2010-05-11 03:41:28 EDT
One more thing i'd like to add. After reboot of the system those "false" entries disappear from nautilus and there is just one entry for ssd card as it supposed to be.
Comment 2 Nikolai Maziashvili 2010-05-13 21:20:06 EDT
Well i found out that maximum number of "extra" storage that comes to Places is 3. So no matter how many times i suspend i get asked every time but number of entries doesn't go above 3.
Please take a look at this very annoying bug.
Comment 3 Nikolai Maziashvili 2010-05-20 15:35:29 EDT
Hi David,
This bug is open for a while and i was wondering if you could at least reproduce it, or it just me having this strange behavior.
Comment 4 Bryan Che 2010-12-04 18:27:29 EST
I have this same problem both on Fedora 13 and Fedora 14 x86_64.
Comment 5 Bug Zapper 2011-06-02 10:12:43 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Nikolai Maziashvili 2011-06-02 20:56:24 EDT
I've got "need info" request on this bug, but considering that i'm running F15 now for a two month i really can't provide any additional information regarding this bug.
I will test it in F15 and if it's solved then i will close this bug. Otherwise change version number.
Comment 7 Nikolai Maziashvili 2011-06-06 12:56:27 EDT
Tested in F15 - problem persists. This bug didn't receive any attention (at least it seems this way) since F13. So would be nice if someone would give any feedback.
Comment 8 Juan J. Martínez 2011-08-12 04:36:24 EDT
I have this problem in F15 too.

In my case, if I unlock on the Gnome dialog, it breaks my disk (appears to be mounted twice). If I cancel to unmount, it works (was already mounted).
Comment 9 Juan J. Martínez 2011-08-12 04:37:33 EDT
Sorry, I meant " If I cancel the dialog and I don't unlock, it works (was
already mounted)."
Comment 10 Juan J. Martínez 2011-08-12 05:11:13 EDT
I have my home encrypted with luks in a SSD card. Because of this issue, I've noticed that the /home directory was appearing twice in the output of mount.

That seems related to Bug #623522. I disabled selinux and sandbox (chkconfig sandbox off), and now the duplicated mount it's gone.

$ mount | grep home
/dev/mapper/luks-cc207472-efa3-4a9f-b699-4780594c9a5a on /home type ext4 (rw,noatime,nodiratime,user_xattr,barrier=1,data=ordered)
gvfs-fuse-daemon on /home/reidrac/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=500,group_id=500)

But when I suspend and get back, I'm asked for my password (OK), and then Gnome asks for a password to unlock the volume.

The only difference on the mount output is that the gvfs-fuse-daemon line is gone.

The it doesn't matter what I do... the disk gives I/O errors and I need to reboot (the works though). gvfsd-metadata crashes if I try to browse the disk.
Comment 11 David Zeuthen 2011-08-12 17:01:08 EDT
The root problem here is that the kernel driver removes and adds the device on suspend/resume. It would be nice to avoid doing that since we don't do it for other buses such as USB. Reassigning
Comment 12 Josh Boyer 2012-06-04 11:05:32 EDT
Is this still happening with the 2.6.43/3.3 kernel updates in F15/F16?
Comment 13 Josh Boyer 2012-07-11 13:52:22 EDT
Fedora 15 has reached it's end of life as of June 26, 2012.  As a result, we will not be fixing any remaining bugs found in Fedora 15.

In the event that you have upgraded to a newer release and the bug you reported is still present, please reopen the bug and set the version field to the newest release you have encountered the issue with.  Before doing so, please ensure you are testing the latest kernel update in that release and attach any new and relevant information you may have gathered.

Thank you for taking the time to file a report.  We hope newer versions of Fedora suit your needs.

Note You need to log in before you can comment on or make changes to this bug.