Bug 591073 - SM GUI : Multiple click “Register System “ button launch multiple box for register.
Summary: SM GUI : Multiple click “Register System “ button launch multiple box for reg...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Pradeep Kilambi
QA Contact: Jeff Weiss
URL:
Whiteboard:
: 607174 (view as bug list)
Depends On:
Blocks: 568421
TreeView+ depends on / blocked
 
Reported: 2010-05-11 11:25 UTC by spandey
Modified: 2015-04-23 23:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:37:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 0 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description spandey 2010-05-11 11:25:25 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Prequisities : 
Rhel6 client with SM version 55

Steps to Repro : 
Login to client console 
execute following command on console 

subscription-manager-gui

press multiple time “Register System “ Button

Expected Result : 
Register Button should disable after launch “Register Box”
I think no use of multiple register box at same moment 

Actual Result : 
Screen got crowded with multiple launched of “Register Box”
at every click console is displaying “{}” sign 
so console got crowded with multiple “{}” sign

Comment 2 RHEL Program Management 2010-05-11 13:12:10 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 wes hayutin 2010-07-22 18:17:07 UTC
raised priority

Comment 6 wes hayutin 2010-07-22 19:03:15 UTC
*** Bug 607174 has been marked as a duplicate of this bug. ***

Comment 7 Justin Harris 2010-08-05 12:48:46 UTC
I made this dialog a singleton, so this should no longer be an issue.  Subsequent clicks of the "Register System" button will simple focus the existing dialog if it is already being shown.  Let me know if a different fix is preferred.

Comment 8 wes hayutin 2010-08-10 16:28:29 UTC
Jeff, please check this out.
Thank you

Comment 9 Jeff Weiss 2010-08-10 16:54:59 UTC
Verified.  commit 4a5305968e771b18bc0db804d323ce1f83c10176

Comment 10 errata-xmlrpc 2011-05-19 13:37:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.