Bug 591074 - RHEL 6 beta kernel cannot detect the HDD which connects to VIA VX900 chip.
RHEL 6 beta kernel cannot detect the HDD which connects to VIA VX900 chip.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Milburn
desktop-bugs@redhat.com
:
Depends On:
Blocks: 534148
  Show dependency treegraph
 
Reported: 2010-05-11 07:26 EDT by Joseph
Modified: 2010-11-15 09:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:24:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph 2010-05-11 07:26:21 EDT
Description of problem:

RHEL 6 beta kernel cannot detect the HDD which connects to VIA VX900 chip.

Version-Release number of selected component (if applicable):

kernel-2.6.32-19.el6.i686.rpm

How reproducible:


Steps to Reproduce:
1. Put the RHEL 6 beta installation DVD and boot it on VIA VX900 platform
2. In storage detection, there is no HDD detected.

  
Actual results:

Cannot detect the HDD.

Expected results:

HDD should be detected

Additional info:

After checking the source RPM of kernel, it looks like the VX900 ID wasn't included. 
Here is a patch in kernel.org.
http://git.kernel.org/?p=linux/kernel/git/next/linux-next.git;a=commitdiff;h=4f1deba435ef75380c1d06fda860c7a15ea16fdf

Maybe you can patch the VT6410/6415/6330 detection issue, too.

http://git.kernel.org/?p=linux/kernel/git/next/linux-next.git;a=commitdiff;h=bc8a67386fd462914269fa93446e1891955a8bb3
Comment 2 RHEL Product and Program Management 2010-05-11 09:12:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Joseph 2010-05-28 02:17:58 EDT
I have no right to check #534148.
Comment 5 Aristeu Rozanski 2010-05-28 16:37:46 EDT
Patch(es) available on kernel-2.6.32-31.el6
Comment 9 releng-rhel@redhat.com 2010-11-15 09:24:09 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.