Bug 591087 - cannot print in landscape orientation
cannot print in landscape orientation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evince (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Marek Kašík
desktop-bugs@redhat.com
:
Depends On:
Blocks: 599016
  Show dependency treegraph
 
Reported: 2010-05-11 08:12 EDT by Vladimir Benes
Modified: 2010-11-10 15:22 EST (History)
2 users (show)

See Also:
Fixed In Version: evince-2.28.2-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:22:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add "Auto Rotate and Center" and "Page Scaling" options to print dialog (121.09 KB, patch)
2010-05-20 09:27 EDT, Marek Kašík
no flags Details | Diff
US letter printed on A4 in landscape by acroread, evince-2.28.2-12 and evince-2.28.2-13 (343.83 KB, application/pdf)
2010-07-14 09:52 EDT, Michal Haško
no flags Details

  None (edit)
Description Vladimir Benes 2010-05-11 08:12:09 EDT
Description of problem:
if I change orientation to landscape in File->page setup then (after pressing ctrl+p) I can check that landscape orientation is selected in print dialog but when print is done the result is still the same no matter if landscape or portrait orientation is selected

Version-Release number of selected component (if applicable):
evince-2.28.2-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.in evince go into File -> Page Setup
2.check landscape orientation 
3.print via ctrl+p dialog
  
Actual results:
result same as if portrait orientation is selected

Expected results:
the top of the page should be printed in the center of the longer page side

Additional info:
firefox landscape printing works well
Comment 1 Vladimir Benes 2010-05-11 08:15:23 EDT
the printing to pdf file is also affected
Comment 3 RHEL Product and Program Management 2010-05-11 10:20:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Marek Kašík 2010-05-20 09:27:46 EDT
Created attachment 415413 [details]
add "Auto Rotate and Center" and "Page Scaling" options to print dialog

Hi,

this is a patch backported from upstream. It adds "Auto Rotate and Center" check button and "Page Scaling:" combo box to print dialog. The combo box contains "None", "Shrink to Printable Area" and "Fit to Printable Area" items.
It doesn't contain possibility to fit page to printable area and center it (has to be implemented and localized upstream).
The patch also includes localizations of the new strings.

Regards

Marek
Comment 7 Michal Haško 2010-07-14 09:51:17 EDT
The latest version of evince is printing landscape, but not the way we think it should be printed.
See the attached pdf now please.
Acroread printed the page landscape and centred, but evince (the other 2 pages) printed the pages on left side.
One may also notice that the version printed with acroread is a bit bigger than the one printed by evince. We think that this is caused because acroread considers the full paper as printable area while evince just the left half We think so because the original printed pdf is in US letter format, but the printed paper is A4 size, which is a bit narrower (i.e. US letter is a bit wider) in ratio. So evince was not able to fit the whole US letter width to half of A4, so it had to shrink the page a bit more and added extra white space to the bottom. But acroread took the whole page as printable area and fitted the wider US latter in landscape just fine.
Am I making myself clear enough? This is not so simple to explain.
What version do we consider to be right? acroread or evince?
Comment 8 Michal Haško 2010-07-14 09:52:40 EDT
Created attachment 431777 [details]
US letter printed on A4 in landscape by acroread, evince-2.28.2-12 and evince-2.28.2-13
Comment 9 Marek Kašík 2010-07-20 07:55:32 EDT
Hi Michal,

the right versions are both. Acroread and evince are just different applications so their results are sometimes different too. In this case we have decided to use upstream's patch for this which doesn't have two controls for Auto-rotation and Center but only one for both.

Marek
Comment 10 Vladimir Benes 2010-09-16 09:29:31 EDT
the landscape printing works now... if the landscape page should be centered or starting from the left edge that's for another discussion
-> VERIFIED
Comment 11 releng-rhel@redhat.com 2010-11-10 15:22:15 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.