Bug 591098 - RFE: please add "take" link to QA Contact field
Summary: RFE: please add "take" link to QA Contact field
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface   
(Show other bugs)
Version: 3.4
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 12:48 UTC by Karel Volný
Modified: 2013-06-24 03:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 17:14:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add (take) link to qa contact field (v1) (2.42 KB, patch)
2010-05-11 17:25 UTC, David Lawrence
nelhawar: review+
Details | Diff

Description Karel Volný 2010-05-11 12:48:11 UTC
Description of problem:
In the show_bug view, the "Assigned To" field has a link "take" next to it which changes the assignment to the current user.

Please add such a link to easily change the "QA Contact" field the same way.

Comment 1 David Lawrence 2010-05-11 17:25:07 UTC
Created attachment 413206 [details]
Patch to add (take) link to qa contact field (v1)

Attaching new patch to add (take) link to qa contact field similar to how the assigned to field works. The code is different though since the qa contact field can be empty where as the assigned to field cannot.

Please review
Dave

Comment 2 Karel Volný 2010-05-12 08:42:03 UTC
(In reply to comment #1)
> Please review

sorry, I don't understand Bugzilla code (well, at least I don't see any obvious typo) ... isn't there a testing Bugzilla interface instance to try in practice?

Comment 3 Noura El hawary 2010-05-12 11:25:22 UTC
Comment on attachment 413206 [details]
Patch to add (take) link to qa contact field (v1)

Patch looks good Dave and works as expected.

Thanks,
Noura

Comment 4 David Lawrence 2010-05-12 17:14:17 UTC
Thanks Noura. Committed and will be in the next update.

Dave


Note You need to log in before you can comment on or make changes to this bug.