Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591132 - magnifiing icon not sensitive
magnifiing icon not sensitive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evince (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Marek Kašík
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 10:06 EDT by Vladimir Benes
Modified: 2010-07-02 15:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: evince-2.28.2-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing check for possibility of zoom (528 bytes, patch)
2010-05-17 08:31 EDT, Marek Kašík
no flags Details | Diff

  None (edit)
Description Vladimir Benes 2010-05-11 10:06:43 EDT
Description of problem:
when zoom level set to 400% the magnifiing icon grays (if set in taskbar) if you then go one level down (by pressing -) the magnifier icon should get sensitive to allow magnify the document back to 400% percent .. but it gets sensitive after one more steps

Version-Release number of selected component (if applicable):
evince-2.28.2-6.el6.x86_64

How reproducible:


Steps to Reproduce:
1.open a document in evince
2.insert zoom icons into toolbar
3.press + several times to reach maximal magnification
4.click - once in taskbar

  
Actual results:
the + should get sensitive to allow magnifiing to max 

Expected results:
it's not sensitive

Additional info:
keyboard + works as expected so just this icon is affected
Comment 1 RHEL Product and Program Management 2010-05-11 10:20:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Marek Kašík 2010-05-17 08:31:58 EDT
Created attachment 414534 [details]
patch fixing check for possibility of zoom

Hi,

the problem is that the test for sensitivity of zoom icons checks whether new zoom level is outside of given range. The test should check whether actual value is inside of the range and also not a border value.

Regards

Marek
Comment 4 Vladimir Benes 2010-06-09 09:04:36 EDT
VERIFIED:
works as expected
Comment 5 releng-rhel@redhat.com 2010-07-02 15:04:39 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.